Author Topic: Liquid UI Scripts Deployment Techniques  (Read 2143 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Liquid UI Scripts Deployment Techniques
« on: October 31, 2017, 12:13:12 PM »
Purpose:
Liquid UI offers very flexible means of deploying the scripts.
Liquid UI supports 4 script directories.
These directories are specified in Liquid UI configuration "guixt.sjs" file or in User Catalog.
Following section discusses various locations Liquid UI scripts can reside.

1. Scripts on the Local drive
2. Scripts on Network file server or a file share
3. Scripts on FTP and/or Web server
4. Scripts on SAP web repository

1. Scripts on the Local drive:
Liquid UI script developers and small testing teams usually use this option.
Pros:
a) Easy setup and use.
b) Developers get complete control of scripts for modifications.
Cons:
a) Not meant for large group of users. High maintenance option.
b) User has control of scripts and users can modify or delete the scripts.
Example:
directory1="C:\\LiquidUI\\Scripts";

2. Scripts on Network file server or a file share:
Even this option can be used for developers, testing teams and end-users.
Pros:
a) Easy setup and use.
b) Centralized management of scripts.
c) Access to scripts can be easily administered with use of network policies, etc.
d) Network traffic can be reduced by using File Replication option in Liquid UI settings
Cons:
a) Additional dependency for using Liquid UI
b) Additional replication, etc must be setup if different servers are used across WAN
c) Additional users privileges must be setup for users to access these scripts
Example:
directory1="\\\\DemoServer\\LiquidUI\\Scripts";

3. Scripts on FTP and/or Web server:
Even this option can be used for developers, testing teams and end-users.
Pros:
a) Can be used across company's internal network.
b) Centralized management of scripts.
c) Network traffic can be reduced by using File Replication option in Liquid UI settings
Cons:
a) Additional dependency on web/ftp server.
b) Script download time can vary. The download time is dependent on server response time.
c) Web/Ftp server access must be setup for all the users.
Example:
directory1="http:\/\/www.demoserver.com\/LiquidUI\/Scripts";
[OR]
directory1="ftp:\/ftp.demoserver.com\/LiquidUI\/Scripts";

4. Scripts on SAP web repository:
This option can be used for developers, testing teams and end-users.
However, it is recommended that this deployment mechanism should not be used for developers.
Pros:
a) Centralized script administration with SAP's transport and correction mechanism.
b) Automatic caching for reducing script downloads.
c) No external dependencies.
d) Change access can be controlled using SAP's authorization mechanism.
Cons:
a) Additional RFC overhead as scripts are retrieved from SAP using Remote Function Calls (RFC).
b) Difficult setup for developers as it is not very easy to change uploaded scripts.
Example:
directory1="SAPWR:ZLUI.DEMO";

« Last Edit: October 31, 2017, 12:56:53 PM by Benjamin Dasari »