Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Sabir Mohammad

Pages: [1] 2 3 4
1
Purpose: To provide user the opportunity of selecting the row label on a Pop-up screen to perform further actions.

Pre-requisites: Liquid UI Android version "3.0.8.0" or later.

Example Steps:
1. Navigate to the transaction "sm04". Select the row and tap on the toolbar pushbutton "session".
2. On the pop-up screen "Back-End Sessions", long tap on a row label until you get the pop-up with options "select | Help". Choose the option "select".
3. The label will be selected. Choose the appropriate pushbutton associated below to perform the intended action.
4. The delete action will be performed and the selected session "create sales order" will be terminated.

Refer to the attachment for further reference.

2
Purpose: To quickly upload the signature on Liquid UI Android via the Liquid UI Server with an automated pushbutton, when compared to regular SFO signature upload.

Pre-requisites:
Liquid UI WS, Liquid UI WS Server, Liquid UI Android version to 3.0.7.0 or later.

Steps:
1. Place the following WS script file "SAPLIQS0.E7200.sjs" in the local directory, as configured in guixt.sjs file of Liquid UI Server folder.

*******************************************************************
pushbutton([3,40], "@JC@Upload Signature", "/_gala_sign", {"size":[1,18]});
pushbutton([3,60], "@5M@View Signature", "?", {"size":[1,18], "process":mi04DisplayAttachment});


function mi04DisplayAttachment(){
    onscreen 'SAPLIQS0.7200'
        enter({'control':'GOSCONTAINERCTRL.Toolbar','item':'%GOS_TOOLBOX;53;102','event':2});

    onscreen 'SAPLIQS0.7200'
        enter({'control':'GOSCONTAINERCTRL.Toolbar','item':'%GOS_VIEW_ATTA','event':1});               
}

*******************************************************************

2. Run the Liquid UI Server on your machine.

3. Configure a Liquid UI Server connection on Liquid UI Android and connect.

4. Navigate to the transaction "iw24" and Select the Liquid UI pushbutton "Upload Signature".

5. Input the signature and Select "Done".

6. Make changes to the file name, if needed on the pop-up and Select "Done".

7. Your signature attachment will be successfully uploaded.                             
Select the Liquid UI pushbutton "View Signature".

8. Double tap the signature file.

9. Select the option "Yes" on the pop-up.

10. Select the appropriate option on the third party application pop-up to view the signature file.

11. You will view the signature file uploaded.


Refer to the attachments for Clarity...

3
Mobile Products (Android, iOS and CE) / Keep SAP Connection Screen Awake
« on: January 17, 2019, 09:57:01 AM »
Purpose:
    To keep the SAP connection screen display awake for the opened session. Even if, there is no activity And the Display Setting's sleep time has been reached.
Steps:
1. From the Server Connections screen, navigate to APP Settings - Symbolically three horizontal lines to the top left corner.
2. Select the option "App Settings".
3. Scroll down the Insider to select the option "Keep SAP Screen On".
4. Go back to Server Connections screen and log in to your SAP server.
5. The SAP connection screen display will be ON, until you manually use the POWER button of the device to turn the Display OFF.

See the attachments for further reference



4
Purpose:
To prompt for user actions within SAP screens and nest the process functions to reuse them. The maximum nested level is 8.

Pre-Requisites:
1. Liquid UI WS.
2. Liquid UI WS Server version 3.5.570.0 & above. (if accessing scripts via WS Server)

Usage:
To trigger a process function using parameters. This command is often used in conjunction with the "onscreen" and "onUIEvents" commands. The perfect use case for "reenter" is "MessageBox" command in LUI Server.

Syntax:
reenter('tcode',{process: functionname, using:{parameter:value}});

Options:
fcode/tcode: Passing SAP transaction code.
process: Calls a function.
using: Passing values to processes.

Liquid UI Code:
Below code demonstrates the usage on SAP Easy Access Screen.
----------------------------SAPLSMTR_NAVIGATION.E0100.sjs-----------------------

//deleting controls on easy access screen
del("P[User menu]");
del("P[SAP menu]");
del("P[SAP Business Workplace]");
del("P[Display role menu]");
del("P[Add to Favorites]");
del("P[Create role]");
del("P[Assign users]");
del("P[Documentation]");
del("X[Image_container]");
del("P[Delete Favorites]");
del("P[Change Favorites]");
del("P[Move Favorites down]");
del("P[Move Favorites up]");

//Creating toolbar pushbutton
pushbutton([TOOLBAR],"Test Reenter","?",{"process":executeFnMessageboxbuttons});
function executeFnMessageboxbuttons ()
{
onscreen 'SAPLSMTR_NAVIGATION.0100'
enter('/nva01');
onscreen 'SAPMV45A.0101'
enter('/nmm01');

onscreen 'SAPLMGMM.0060'
println('Calling MessageBox and wait for user.\n\n');
reenter({process:procLUImessagebox_1, using:{title:'This is the title of messagebox', message:'THis is the message', type:MB_YESNO}});
       
onscreen 'SAPLMGMM.0060'
println('Continuing execution after reenter!!!......');
println('_eventid=*'+system.stringify(_eventid)+'*');
switch(_eventid)
{
   case 'YES':
println('\nUser Clicked YES');
break;
   case 'NO':
println('\nUser Clicked NO');
break;
}
println('_last_fcode: '+_last_fcode+'\n\n');
enter('/15');

onscreen 'SAPLSMTR_NAVIGATION.0100'
println('Second Event on first process continues.....');
println('Calling MessageBox_2 and wait for user.\n\n');
reenter({process:procLUImessagebox_2, using:{title:'This is the title of messagebox', message:'THis is the message', type:MB_YESNO}});

onscreen 'SAPLSMTR_NAVIGATION.0100'                           
}
function procLUImessagebox_1(pUsing)
{
// when in reenter, this PREFC section gets executed FS
println('inside procLUImessagebox_1');
println('title=*'+pUsing.title+'*');         
enter('/o');
       
onscreen 'RSM04000_ALV_NEW.2000'
goto resize_repaint;

onscreen 'RSM04000_ALV.2000'
resize_repaint:;
println('onscreen RSM04000_ALV.2000 _eventid=*'+_eventid+'*\n\n');
clearscreen();
windowsize([5,5,50,8]);
title(pUsing.title);
//Draw the interface with buttons
switch(pUsing.type) {
   case MB_YESNO:
pushbutton([1,1],'Yes','/12',{'eventid':'YES'
pushbutton ([1,10],'No','/12',{'eventid':'NO'});
pushbutton ([1,15],'Not Text','/12',{'eventid':{val:45, str:'this is a long string', vbool:false}});
break;
}                     
}
function procLUImessagebox_2(pUsing)
{
// when in reenter, this PREFC section gets executed FS
println('inside procLUImessagebox_2');
println('title=*'+pUsing.title+'*');           
enter('/o');
onscreen 'RSM04000_ALV_NEW.2000'
goto resize_repaint;
onscreen 'RSM04000_ALV.2000'
resize_repaint:;
println('onscreen RSM04000_ALV.2000 _eventid=*'+_eventid+'*\n\n');
clearscreen();
windowsize([5,5,50,8]);
title(pUsing.title);
//Draw the interface with buttons
switch(pUsing.type) {
    case MB_YESNO:
pushbutton([1,1],'Yes','/12',{'eventid':'YES'});
pushbutton ([1,10],'No','/12',{'eventid':'NO'});
pushbutton ([1,15],'Not Text','/12',{'eventid':{val:45, str:'this is a long string', vbool:false}});
 break;
 }
 onscreen 'UNREACHABLE_PROGRAM.0000'
 enter();

 onscreen 'UNREACHABLE_PROGRAM.0000'
 enter();         
}

5
Purpose:
To use the "eventid" parameter of push button and conditionalize the script with help of  "_eventid" system variable for displaying the event.

Pre-Requisites:
1. Liquid UI WS version 1.2.332.0 & above.
2. Liquid UI WS Server version 3.5.572.0 & above.(if accessing scripts via WS Server)

Syntax:
pushbutton([2,4], "name of button",{"eventid":"event name"});

Liquid UI Code:
Below code demonstrates the usage on SAP Easy Access Screen.
---------------------------- SAPLSMTR_NAVIGATION.E0100.sjs ----------------------
del("X[IMAGE_CONTAINER]");
pushbutton([2,4], "Order",{"eventid":"book"});
pushbutton([2,15], "Exit",{"eventid":"leave"});
if(_eventid=='book')
{
  message('You are about to confirm the order',{"title":"Confirmation","type":64});
    }
if(_eventid=='leave')
{
   message('You are about to leave the page',{"title":"Exit","type":64});
    }

See attachments for further reference...

6
Purpose: To compress and upload the image and video files using SFO.
Steps:
1. Navigate to a transaction with SFO like "IW24" and select "Create attachment".
2. From the Pop-up, select either option "Take picture or video" or "Choose picture from album"-in this case.
3. Select the file from the pop-up list.
4. Select the appropriate option for file compressing.
5. Name the file or use the auto-generated file name and click "OK".
6. File will be attached. Save the notification.

See the attachments for further reference.

7
Purpose: To quickly navigate back to the current session saving time and clicks.
Steps:
1. Navigate to "App Settings" from the connection list screen.
2. "Turn on" the "Display Notification" from "Insider".
3. Navigate back, Login to your server and minimize the application.
4. Select the "Liquid UI Notification" to the top left corner on the screen.
5. Select "CURRENT SESSION".
6. You will be navigated back to the same screen that you were working previously.

Conclusion: Display Notification feature allows the user to attend to other tasks on the device and navigate back quickly to same screen where he previously left from.

See Attachments for further reference.

8
Purpose: To view the uploaded attachments via "SFO" using the "Quick Look" option.

Steps:
1. Navigate to the "attachment list" under "SFO".
2. Double-click the attachment.
3. Select the option "Quick look".
4. The attachment will open, Click "Done".

See Attachments for further reference.

9
Purpose: To activate the Portal license on Liquid UI Android or IOS.

Steps:
1. Open the license mail sent to the registered mailid on mobile device and select "click here".
2. A pop-up may appear, select the appropriate option.
3. You will get the success message, Click "OK".
4. You can further verify the license activation, by navigating to the "Insider" under "App Settings".

Note:
You can also use "license code" to activate the license.

See Attachments for further reference.

10
Purpose: To turn the "input field" history on/off.

Steps:
1. Navigate to the "App Settings" from the connection list screen.
2. In the "Insider", toggle the option "Input field history" accordingly.
3. Navigate to any transaction to see the result.

See the attachments for further reference.

11
Purpose: To change the font to "monospace" styles.
Steps:
1. Login to your SAP server.
2. Tap on your Server name to the right bottom corner on the screen and select the option "Font Selection".
3. On the pop-up "Font Selection", scroll to select the desired monospace font style and Tap "OK".
4. The font style will be changed.

See the Attachments for further reference...

12
Mobile Products (Android, iOS and CE) / Clearing Cache on Liquid UI IOS
« on: February 01, 2018, 09:40:29 AM »
Purpose: To clear the "tcode search" and "inputfield history" cache memory.
Steps:
1. Navigate to the connection list screen and tap on the menu settings on the top right corner (typically horizontal lines).
2. Tap on the option "Clear Cache".
3. Tap on "OK".

See the attachments for further reference.

13
Purpose: Liquid UI screen modification enabled to a particular or multiple systems.

Pre-Requisites:
Make sure that the SAPgui is closed on the desktop before following these steps.

Steps:
1. Locate the file "guixt.sjs" from the following path.
    "C:\Program Files\SAP\FrontEnd\SAPgui"           --> 32Bit O.S
    "C:\Program Files (x86)\SAP\FrontEnd\SAPgui"  --> 64Bit O.S

2. Make the following entry to the file.
    enablesystem = "SYSTEM ID";                           --> for single R/3 system.
          Example: enablesystem = "TRT";                  --> only TRT can access the scripts.
    enablesystem ["SYSTEM ID", "SYSTEM ID"];     --> for multiple R/3 systems.
         Example: enablesystem ["TRT", "TTX"];         --> multiple systems can access the scripts.

Refer attachments for clear understanding.

14
Mobile Products (Android, iOS and CE) / Using GPS on Liquid UI IOS
« on: January 18, 2018, 10:31:45 AM »
Purpose:
      This option helps in tracking the notification or order or document number generated by the field personnel or the end user with help of the geographical coordinates of the device.
Pre-requisite:
Enable the "Location Services" from Device Settings.
Steps:
1. Navigate to any transaction.
2. Single tap and hold on the desired input field until the bubble appears.
3. Release the tap for the options to popup, then select "GPS".
4. The geographical coordinates will be automatically fetched and populated in the field.

See attachments for further reference.

15
Purpose: To identify the installed Liquid UI Client version on the iOS and Android device(s).

Steps:
1. Navigate to the connection list screen.
2. To the top corner, click on the three horizontal lines (Settings).
3. Click "About".

Refer Attachments for further reference

Pages: [1] 2 3 4