Recent Posts

Pages: 1 [2] 3 4 ... 10
11
Pre-Requisites
+++++++++++++++++++++++++++++++++++++++++++++++++
SAP Secure Login Client must be installed on the Liquid UI Server
Liquid UI Server must run under a AD Domain Admin account
SAP PSE certificate must be exported and installed on Liquid UI Server

sapproxy.ini  Proxy configuration as per below
+++++++++++++++++++++++++++++++++++++++++++++++++
[Proxy1]
ListenPort = 3297
TargetServer = HELIOS
TargetServerPort = 3200
GuiXT = 10
snc_lib=C:\Program Files\SAP\FrontEnd\SecureLogin\lib\sapcrypto.dll
sncname = CN=SAPSNCID7, OU=IT, OU=SYNACTIVE, O=SYNACTIVE C=US
SNCMode=3
SNCSSO=0

Connectivity Details
1. SAPGUI to Liquid UI Server will be SAP username and password based logon - without encryption
2. iOS/Android Liquid UI Clients can be connected to Liquid UI Server via TLS1.3 and can be encrypted

12
Download TSC SAP Device Types from below link
https://usca.tscprinters.com/en/downloads
Use Filter: Desktop
Printer Serices: TE Series ....

SAP Device Types Download from above link attached including Documentation

Use SPAD transaction in configuration client to import these .pri files
Menu: Utilities->For Device types->Import

Once these are installed, using SPAD, specify Output Device: TSC and click on Display
Click on Change Icon on toolbar
Select YTSC200 as Device Type from the dropdown
Save

*Once the above setup is completed, go to the transaction and print by selecting TSC as Output Device and Selecting Print Now checkbox.
These should generate a front end data print stream that the TSC printer would understand and print appropriate content. *

Additional refer to
SAP Note 1540910
13
Operation System: Windows *ONLY*
Pre-Requisites - Liquid UI Server must be installed, licensed and running

After downloading the zip file, and the attached document please execute admin.exe to launch the Admin Console for Liquid UI Server

14
Purpose:
Required RFC authorizations for 'RFC_READ_TABLE' function module.

1. S_RFC: RFC_TYPE=FUGR, RFC_NAME=SYST, ACTVT=16
Note: Needed for sapnwrfc which is the newer RFC library from SAP


2. S_TABU_NAM: ACTVT=03, TABLE=SRGBTBREL
Note: Needed to check if attachment exists for work order or not (Table name will change as needed)




Liquid UI Code:
----------------------------------------------------------------------------------------------------------------------------------------------
Script File Name: SAPLCORU.E3200.sjs       // IW41 Actual Data
----------------------------------------------------------------------------------------------------------------------------------------------
// Load the generic functions
load("stringFunctions.sjs");

// User Interface
pushbutton([TOOLBAR], "@4P@Attachments", '?', {'size':[2,32], 'process':iw41_viewAttachments});


// Related functions
// Function to open attachment list if it exists

function iw41_viewAttachments(){
   println("\n ==== Entered function iw41_viewAttachments ===\n");
   
   set("V[z_iw37n_order]","&F[Order]");
   var result = attachmentListExists(z_iw37n_order,12);
   if(!result){
      return("E: No attachments exists");
   } else {
      setcursor("F[Order]");
      enter('/2');
   }
   
   onscreen 'SAPLCOIH.3000'
      enter({'control':'GOSCONTAINERCTRL.Toolbar','item':'%GOS_TOOLBOX;75;89','event':2});      //Object for services
      
   onscreen 'SAPLSWUG.0100'   
      set("cell[TABLE,0,1]","X")
      enter();
      
   onscreen 'SAPLCOIH.3000'
      enter({'control':'GOSCONTAINERCTRL.Toolbar','item':'%GOS_VIEW_ATTA','event':1});              //Attachment List
   
}


// Function uses RFC call to check if attachment list exists for order
function attachmentListExists(strDocNum, nPadding, strYear){         
   println("\n ==== Entered function attachmentListExists ===\n");
   
   var z_in_query_table = "SRGBTBREL";
   if(hasValue(strYear)){
      var z_options = ["INSTID_A = '" + (padString(strDocNum,nPadding,PADDING_LEFT,"0")) + strYear + "'"];
   } else {
      var z_options = ["INSTID_A = '" + (padString(strDocNum,nPadding,PADDING_LEFT,"0")) + "'"];
   }
   var z_fields = ["INSTID_B"];
   var z_InstanceID = [];
   var bResult = false;

   rfcResult = call("RFC_READ_TABLE", {"in.QUERY_TABLE":"z_in_query_table",
                              "table.OPTIONS":"z_options",
                              "table.FIELDS":"z_fields",
                              "table.DATA(width:3000)":"z_InstanceID"});
   println("=====>> Check RFC_READ_TABLE Exception="+rfcResult.exception+"<==");
   println("=====>> Check z_InstanceID.length="+z_InstanceID.length+"<==");
   //FOL18          4 EXT44000000000134
   
   if(z_InstanceID.length>0){
      bResult = true;
   }
   return bResult;
}


See attachments for code samples!

15
Symptoms
When you use Liquid UI to open a dialog window with certain Windows OS[19042.1083, 19042.1165] to select a file, you receive Javascript runtime error related to insufficient memory.
"CommonDialog: The common dialog function failed during initialization. This error often occurs when insufficient memory is available".

This article provides work around to the issue.


Resolution/Work around(a classic select file window shows up):
Change the flags as specified below in getFilesToUpload() function:

function getFilesToUpload(szPrompt)

    if(szPrompt==void 0) szPrompt = 'Select File';
    var dialog = new ActiveXObject('MsComDlg.CommonDialog');
    dialog.Filter='All Files(*.*)|*.*'; 
    dialog.MaxFileSize=32767; 
    dialog.DialogTitle=szPrompt;
    //dialog.Flags=0x200|0x80000|0x800|0x4|0x200000; // FAILS because of 0x80000
    dialog.Flags=0x200|0x800|0x4|0x200000;  // WORKS, but fails if there is no 0x200
    dialog.ShowOpen(); 
    //var ret = dialog.FileTitle;
    var ret = dialog.FileName;
    dialog = void 0;
    return ret;



Findings 1: dialog.Flags=0x200|0x80000|0x800|0x4|0x200000; // FAILS because of 0x80000
Findings 2: dialog.Flags=0x200|0x80000|0x800|0x4|0x200000; // WORKS if high contrast mode of windows is turned on, Search for high contrast using windows search at bottom of the screen, and 'Turn on high contrast'
Findings 3: dialog.Flags=0x200|0x800|0x4|0x200000;  // WORKS
Findings 4: dialog.Flags=0x800|0x4|0x200000;  // Fails if there is no 0x200


16
For generating logs and bins for any execution related issues when using Liquid UI Server or Liquid UI Desktop
please follow below steps

Log in to SAP, and to generate logs type in transaction code box


1.   /ws_blackbox=1
2.   /ws_log=1
3.   Perform the action that needs to be recorded, typically the issue that is been identified by the user on execution of a transaction/process.
4.   /ws_log=0
5.   /ws_backbox=0

This will generate the log files and associated txt/bin files.

Provide this to support@guixt.com with detailed description of the issue along with the generated log and txt/bin files
for investigation

17
Requirements:
Managing software installation and scripts for user's across multiple locations

Pre-Requisites:
Liquid UI Desktop (Local user software deployment), or Liquid UI Server (Central Software Deployment)

Scenario 1: 
The scripts are common across all locations from where user is required to access the solution.
[One set of scripts for all locations]

Preferred Solution:
- Deploy software centrally using Liquid UI Server
- One Configuration file for all users across location
- Depending on the number of users, install single Liquid UI Server or multiple Liquid UI Servers and load balance them using a 3rd party hardware load balancer.
  Refer to Server Sizing Requirements: https://www.guixt.com/knowledge_base/content/18/310/en/32-server-sizing-requirements.html
- Deploy the scripts either locally on the Liquid UI Server or SAP Web Repository
  Refer to Script Deployment Options: http://www.guixt.com/forum/index.php/topic,317.msg321.html#msg321
- Set up SAPGUI Connection to Liquid UI Server for all users.  ** No Need to Activate GuiXT" on end user's machine

Scenario 2: 
The scripts are different for individual locations from where user is required to access the solution.
[Multiple et of scripts for all locations]

Preferred Solution:
- Deploy software centrally using Liquid UI Server for each location
- Separate Liquid UI Configuration file or each location identifying the script location
- Depending on the number of users at each location, install single Liquid UI Server or multiple Liquid UI Servers and load balance them using a 3rd party hardware load balancer.
  Refer to Server Sizing Requirements: https://www.guixt.com/knowledge_base/content/18/310/en/32-server-sizing-requirements.html
- Deploy the scripts either locally on the Liquid UI Server or SAP Web Repository
  Refer to Script Deployment Options: http://www.guixt.com/forum/index.php/topic,317.msg321.html#msg321
- Set up separate SAPGUI Connection to Liquid UI Server for users specific to their location .  ** No Need to Activate GuiXT" on end user's machine
  This will require different SAPGUI connection details based on where the user is located.

Alternatively:
- User's can be assigned different role based on their location, and a usercatalog can be setup which is role specific
- The usercatalog allows specification of groups and directories based on groups
- This way solution can be deployed using Scenario 1.
- Refer to article for using usercatalog: http://www.guixt.com/forum/index.php/topic,152.msg156.html#msg156


With Liquid UI Server deployment approach 
  a. Both software and configuration can be maintained centrally, and no software files and associated configuration files needs to be
      deployed to each individual users.
  b. Scripts can stay either centrally on Liquid UI Server folder or in SAP Web Repository depending on customer's preference.
  c. Mobile ready, to leverage the solution on iOS, Android and Windows CE based devices



With Liquid UI Desktop Deployment Approach
  a. Software needs to be installed on each individual user's machine.
  b. Software configuration files needs to be installed on each individual user's machine.
  c. Software upgrade will require each user's machine to be updated.
  d. If scripts are stored using network share location, then their is additional dependency on the network share, if the share is not accessible, the Liquid UI Solution is not accessible

Note:
With both Desktop and Server Deployment, there are multiple options to deploy the scripts.
Refer to article: http://www.guixt.com/forum/index.php/topic,317.msg321.html#msg321




18
Liquid UI Server aka GuiXT Server / Upgrading Liquid UI Server
« Last post by umang@guixt.com on February 02, 2022, 10:46:49 AM »




http://updates.guixt.com/secured/v617_x64.zip
username: guixt.dnld
password: guixt950
 
Below are the steps to update the software
1. Download the new release from the link provided (Version 3.5.617.0), and extract the files (sapproxy.exe and webscript.dll)
2. Make a backup of existing files (sapproxy.exe and webscript.dll) in the current software install location
3. Stop the Liquid UI Service
4. Copy the new extracted files to the software install location  (sapproxy.exe and webscript.dll)
5. Re start the Liquid UI Service

As with any software upgrade, please test your existing scripts before upgrading the production envinronment.

Please check any scripts that has
- Reference to SAP table which is referred by using Non English Language, if so change it to technical name.  You can put the cursor on the table cell and perform F1 to retrieve technical details of the table

19
Issue:
While connecting to S/4 HANA environment using Liquid UI for Windows Mobile/CE, even though a valid license exist, a license error popup shows up on the UI

Reason:
Launching system>status from the menu bar did not launch the usual, expected system status screen.
Instead, it displayed avery restricted subset of the information under the header ?Repository Data? ?

Resolution:
For solution see SAP Note 2658772.

SAP_BASIS version 7.53 has now introduced a new authorization check on system>status.
The contents of this popup is now restricted through the authorization object S_SYS_INFO.
There was no restriction on this in the earlier versions.
In order to get back the unrestricted view, you will need to create a new role containing the above object, or add it to an existing role, with the below field values ?

ACTVT:
03 (Display)

INFO:
USER (to view the ?user data? section)
SYSTEM (to view the ?SAP system data? section)
HOST (to view the ?host data? section)
DB (to view the ?database data? section)
KERNEL (to access the kernel information)
* (to view everything)

20
The purpose of Liquid UI Server is for central software deployment.  No software footprint on user's local machine.

The scripts are developed on developer's desktop using local SAPGUI and local software installation
This way the scripts are accessible to the developer on their own machine, and Liquid UI console window is available for the developer to debug
any issues.  This is the preferred method in a multi developer environment.

The developed scripts are then then deployed centrally using web repository, or network share.

Also when deploying the software centrally using Liquid UI Server, the production and non production environment shoule be executed on different machines
to prevent any disruptions in production environment usage

Liquid UI Server for development can also be executed in console mode as and when need,
which can provide access to the console window for additional debugging at the Server Level



Pages: 1 [2] 3 4 ... 10