Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
There is no impact
We do not use Java or log4j module
22
LiquidUI - SAP NetWeaver AS ABAP SSO
Workflow for iOS and Android Clients

SAP Communication Channels


See Diagram in attached file, which shows the connection from Liquid UI iOS-Android Clients to LUI Server secured using TLS 1.3


From LUI Server to SAP ECC, connection is established as SAP's trusted server SSO, using SAP's digitally signed Logon Ticket.

On both ends of the Server the connections are secured.  One via TLS 1.3 and the other via Trusted Server Logon Ticket


Trusted Server Connection to SAP ECC is compressed, and the SAP ECC Kernel does not support further encryption.  This SAP Native protocol is not https traffic.
Synactive recommends the LUI server be placed close to the SAP ERP Server to the maximize the optimizing feature as well as to ensure security.
Furthermore, the trust relationship established between LUI Server and SAP ECC ensures that no 3rd party can access this Trusted Server Channel.
Trusted Server Connection is needed not only in the Desktop mode, but it is a necessity in the Mobile environment, where there is no Kerberos SSO.  Connection to LUI Server from the Mobile device is protected by TLS 1.3.
23
LiquidUI - SAP NetWeaver AS ABAP SSO


SAP Communication Channels


See Diagram in attached file, which shows the connection from SAP GUI to LUI Server via the standard SAP's SNC interface. There are no changes in SAP GUI other than service principal.  Available only with Cybersafe TrustBroker

From LUI Server to SAP ECC, connection is established as SAP's trusted server SSO, using SAP's digitally signed Logon Ticket.

On both ends of the Server the connections are secured.  LUI Server connects via standard SAP secure channels.  One via Kerberos and the other via Trusted Server Logon Ticket.

24
Use below registry entry to Activate GuiXT in SAPGUI

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\SAP\SAPGUI Front\SAP Frontend Server\Customize]
"GuiXT"=dword:00000001
25
Purpose: To Calculate the sum of two inputfields using Liquid UI WS

Please follow the below steps:

Step-1: Open the Script file "SAPLSTMTR_NAVIGATION.E0100.sjs" or Create it if it is not present in the WS Directory as configured in the "guixt.sjs" file.

Step-2: Add the below Code Snippet and Save it.

//Deleting the Screen Controls
//Liquid UI Code:
del("X[IMAGE_CONTAINER]");
del("P[User menu]");
del("P[SAP menu]");
del("P[SAP Business Workplace]");
del("P[Display role menu]");
del("P[Add to Favorites]");
del("P[Delete Favorites]");
del("P[Change Favorites]");
del("P[Move Favorites down]");
del("P[Move Favorites up]");
del("P[Create role]");
del("P[Assign users]");
del("P[Documentation]");

//Function to Increment the Total Field from the Quantity Field
function Increment(param){
var total1=parseInt(z_quantity);
var total2=parseInt(z_total);
var output=total1+total2;
set("V[z_total]",output);
}

//Design Screen
inputfield( [12,73], "Total", [12,86],{ "name":"z_total", "size":32});
inputfield( [10,73], "Quantity", [10,86],{ "name":"z_quantity", "size":32});
pushbutton([14,93], "@01@",{ "process":increment, "size":[2,12], "using":{ "quantity":"z_quantity", "total":"z_total" }});

Step-3: Enter the Values in the inputfields and Click on the Pushbutton.

Step-4: It will calculate the Sum and display the result in the inputfield.


Refer to the Attachment for clarity....
26
Purpose: Achieving Tab functionality using Arrow Keys for an Editable Input Field.
Pre-requisites:  Liquid UI Android version 4.0.8.0 and above

Steps:
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. For Example, navigate to VA01 Transaction and Tap on Right arrow Key on a Qwerty keyboard to navigate to the next Editable input field.
4. Tap on Left Arrow Key on a Qwerty keyboard, it will do a Tab and go to Previous Input Field.


Refer to the Attachment for Clarity....
27

Symptoms
When you use Liquid UI to open a dialog window to select a file, you receive error related to MsComdlg or CommonDialog.
This article provides resolution to the issue.

Resolution:
Download the comdlg32 files(comdlg32.dll and comdlg32.ocx):
Comdlg32 files (click here)
OR
Paste the below link in your browser:
http://updates.guixt.com/downloads/comdlg32.zip

Steps to register the ocx file:
Step 01: After the download of comdlg32.zip
Step 02: Extract comdlg32.zip
Step 03: Place the files in "C:\Windows\SysWOW64" folder
Step 04: Open command prompt as admin and run the below commands:
            cd C:\Windows\SysWOW64
            regsvr32 comdlg32.ocx
28
Purpose: To Provide the user the ability to open their SAP transaction documents/files within the application to avoid using any third party application for the same.
Pre-requisites:  Liquid UI Android version 4.21.17.5 and above.
Steps:
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. Navigate to IW22 transaction. Tap on the SFO attachment button.
4. In "Services Object" select "Attachment list".
5. On Attachment list screen, select "xlsx" file and tap on the display icon.
 
Result: The User will able to view the "xlsx" file in the file viewer.
 
Note: Inbuilt viewer also supports pdf, docx and images.


Refer to the Attachment for Clarity....
29
Purpose: To help the user to replace the existing value within the input field upon scan.
Pre-requisites: Liquid UI Android version 4.21.16.0 and above.
Steps:
1. Launch Liquid UI Android.
2. Connect to your SAP Server.
3. In "VA02" Transaction, On Screen "Create Sales Order: Initial Screen", long Tap on Input field. Tap on Scan, the device's camera will open to scan the QR code.
4. Scan the code, after a successful scan, Tap on Done.

Result: The Order type "AA" replaced the existing value "OR" in the input control.

Note: This Functionality is supported in Handheld Scan guns.

Refer to the Attachment for Clarity....
30
Purpose: Below Article would help in creating pushbutton inside the Liquid UI Table using Liquid UI WS.

Pre-requisites:
Liquid UI WS

Example:

Following are the steps that needs to be followed:

Step-1:Open the Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the ?guixt.sjs? file.
Create the file if it doesn't exists.

Step-2: Add the below code snippet and save it.

//Liquid UI Code:
del("X[IMAGE_CONTAINER]");
table([1,1], [10,20], {"name":"z_luitable", "title":"LIQUID UI TABLE", "rows":10});  // Liquid UI Table Generation
column('Status',{"table":"z_luitable", "name":"doc_push", "position":2, "size":10, "label":"", "pushbutton":true,"fcode":"?","process":Test});

Step-3: Refresh the SAP GUI Screen.


Refer to the Attachment for clarity....
Pages: 1 2 [3] 4 5 ... 10