Recent Posts

Pages: 1 ... 8 9 [10]
91
Purpose: To generate Liquid UI LicenseManagementPortal License and installation of that generated license on a Liquid UI Client (Android and iOS) device.

Liquid UI Enterprise Portal License Generation:
After logging into the License Management Portal, you can follow Add User(s) link,
which contains the instructions (steps 1 - 4) to get the license(s) assigned to the user for installation on the Liquid UI Client devices.

Liquid UI Enterprise Portal License Installation:
After Step 4, in the above specified link, the user can follow the instructions specified in the License installation documentation, for Liquid UI Client, based on the below,
Liquid UI for Android
Liquid UI for iOS

Note: You can use one added USER(S)' email (generated email, with LMPLicense), to apply Liquid UI License(s) on multiple Liquid UI Client devices.
92
Purpose: To resolve issue concerning Liquid UI Designer Display resolution.

Issue Screen:


Investigation: As an initial step of the investigation, verify Scale and Layout of your Windows PC
1. Resolution.
2. Size of Text, Apps and other items.


Resolution: Change the value to be 100% for Size of Text, Apps, and other items.




93
var dialog = new ActiveXObject('MsComDlg.CommonDialog');
dialog.Flags=0x200|0x80000|0x800|0x4|0x200000

File Open/Save Dialog Box Flags:

Constant                                      Value                                            Description
cdlOFNReadOnly                             0x1                           Checks Read-Only check box for Open and Save As dialog boxes.
cdlOFNOverwritePrompt                 0x2                           Causes the Save As dialog box to generate a message box if the selected file already exists.
cdlOFNHideReadOnly                      0x4                           Hides the Read-Only check box.
cdlOFNNoChangeDir                       0x8                           Sets the current directory to what it was when the dialog box was invoked.
cdlOFNHelpButton                          0x10                         Causes the dialog box to display the Help button.
cdlOFNNoValidate                           0x100                       Allows invalid characters in the returned filename.
cdlOFNAllowMultiselect                   0x200                       Allows the File Name list box to have multiple selections.
cdlOFNExtensionDifferent               0x400                       The extension of the returned filename is different from the extension set by the DefaultExt property.
cdlOFNPathMustExist                      0x800                       User can enter only valid path names.
cdlOFNFileMustExist                        0x1000                     User can enter only names of existing files.
cdlOFNCreatePrompt                      0x2000                     Sets the dialog box to ask if the user wants to create a file that doesn't currently exist.
cdlOFNShareAware                         0x4000                     Sharing violation errors will be ignored.
cdlOFNNoReadOnlyReturn              0x8000                     The returned file doesn't have the Read-Only attribute set and won't be in a write-protected directory.
cdlOFNExplorer                               0x0008000               Use the Explorer-like Open A File dialog box template.  (Windows 95 only.)
cdlOFNNoDereferenceLinks            0x00100000              Do not dereference shortcuts (shell links) default, choosing a shortcut causes it to be dereferenced by the shell.  (Windows 95 only.)
cdlOFNLongNames                         0x00200000              Use Long filenames.  (Windows 95 only.)


Different Show Methods available for Common Dialog:
dialog.ShowOpen();     // Common Dialog Open Box
dialog.ShowSave();      // Common Dialog Save As window
dialog.ShowFont();       // Common Dialog Font window
dialog.ShowPrinter();    // Common Dialog Printer window
dialog.ShowColor();      // Common Dialog Color window
dialog.ShowHelp();       // Common Dialog Help window
94
Purpose: To provide installed Liquid UI Android License Information on the Android device.

Steps to navigate to Liquid UI Android Insider (App Settings) Screen, for License Section.
1. Open "Liquid UI" app on your device and click on the "Menu" icon at the top left corner.
2. Click on the "App Settings".
3. Scroll vertically to "License" section in Insider screen.
4. Tap and Hold on the "License" section, for "License information" Pop Up.




95
Purpose: Download and installation of Liquid UI Designer on a Physical or a Virtual Machine.

Software download link, for the latest version of Liquid UI Designer Download

Note: Installation of the above Setup file(s), needs to be performed by an ADMIN on the machine, and as an Administrator (Right Click on the .exe, and choose "Run as administrator".

Default Liquid UI Designer installation location, on a Windows Machine
32 Bit O.S  -->  C:\Program Files\Liquid UI\LUI Designer
64 Bit O.S  -->  C:\Program Files (x86)\Liquid UI\LUI Designer

License is required to Execute Liquid UI Designer software.
Request Liquid UI Designer license from Synactive.
Installation of Liquid UI Designer License.
96
Purpose: Download and installation of Liquid UI Server on a Physical or a Virtual Machine.

Highly Recommended: Installation of latest or available SAPgui

Software download links, for the latest version of Liquid UI Server
32 Bit O.S  -->  Download
64 Bit O.S  -->  Download

Note: Installation of the above Setup file(s), needs to be performed by an ADMIN on the machine, and as an Administrator (Right Click on the .exe, and choose "Run as administrator".

Default Liquid UI Server installation location, on a Windows Machine
32 Bit O.S --> C:\Program Files\Liquid UI\Liquid UI Server
64 Bit O.S --> 32 Bit Liquid UI Server Software --> C:\Program Files (x86)\Liquid UI\Liquid UI Server
64 Bit O.S --> 64 Bit Liquid UI Server Software --> C:\Program Files\Liquid UI\Liquid UI Server

Below step is needed only, if Liquid UI Server being Migrating Liquid UI Server to New Hardware
Please copy and paste, the below from the Backup
   1. SAPPROXY.ini
   2. GuiXT.sjs


License is required to Execute Liquid UI Server software.
Request Liquid UI Server license from Synactive.
Installation of Liquid UI Server License.

97
Purpose: To Troubleshooting steps when executing Liquid UI Server.
Issue: Modified screens not displayed when scripts are being executed from SAP Web Repository and connections are through Liquid UI Server.

Steps to STOP Liquid UI Service:
1. Windows + R, Type Services.MSC.
2. Navigate to Synactive R/3 Proxy in the list of Services.
3. Select "Synactive R/3 Proxy", and choose "STOP" service option.

GuiXT.sjs Flags, to display console log for debugging
OPENCONSOLE    =    0x00008000;
HIDECONSOLE    =    0x00000000;
TRACE_RFCCALL   =    0x10000000;

// TRACEFLAGS = HIDECONSOLE;
TRACEFLAGS = OPENCONSOLE;
// TRACEFLAGS = OPENCONSOLE|TRACE_RFCCALL;

Steps to open Liquid UI Server in Console Mode
Method 1: Using Batch File
Navigate to Liquid UI Server installed folder, and execute "ConsoleMode.bat" file.

Method 2: Using command prompt
Step 1: Windows + R, type "cmd" and hit "Enter"
Step 2: In command prompt, navigate to Liquid UI Server installed folder.
Step 3: Once in the desired folder in command prompt, type SAPPROXY.exe -debug
Step 4: The command prompt window, will be used as a Debug window.

Files needed to Read Liquid UI Scripts from SAP Web Repository
LibRFC32.dll in Liquid UI Server folder, when Liquid UI Server is executed in console mode.
LibRFC32.dll in,
32Bit O.S --> C:\Windows\System32
64Bit O.S --> C:\Windows\System32
64Bit O.S --> 32Bit Liquid UI Server Software --> C:\Windows\SysWOW64
98
Purpose: Different options in Liquid UI Table columns

Syntax:
Numeric Input:                "numeric":true
Read-Only Column Field: "readonly":true
Uppercase:                      "uppercase":true

Searchhelp options
  • SearchHelp:                         "searchhelp":
  • SearchHelp Selection Name:"shselname1":
  • SearchHelp Selection Value: "shselvalue1":
  • SearchHelp Name:                "shname1":
  • SearchHelp Destination:       "shdest1":

table([15,1], [25,150], {"name":"z_engr_bomtable", "title":"Create BOM", "rows":10});                                       // Liquid UI Table Generation
column("Item", {"table":"z_engr_bomtable", "name":"item_no", "position":1, "size":4, "numerical":true});         // Liquid UI Column accepting only Numeric Values
column("Document", {"table":"z_engr_bomtable", "name":"doc_no", "position":2, "size":25, "searchhelp":"CV01", "shselname1":"DOKAR", "shselvalue1":"DES",
                                    "shname1":"DOKAR","shdest1":"cell[z_engr_bomtable,Type,row]","uppercase":true});
column("Type", {"table":"z_engr_bomtable", "name":"doc_type", "position":3, "size":3, "readonly":true});         // Liquid UI Column Read-Only
column("Part", {"table":"z_engr_bomtable", "name":"doc_part", "position":4, "size":3, "searchhelp":"CV01", "fname0":"DOKTL", "uppercase":true});         // Liquid UI Column changing the input to UPPERCASE
column("Version", {"table":"z_engr_bomtable", "name":"doc_version", "position":5, "size":2, "searchhelp":"CV01", "fname0":"DOKVR", "uppercase":true});

99
Purpose: Enterprise License re-installation with an upgrade to the latest version of Liquid UI for Android App from Google Play.

Pre-Requisite:Liquid UI Portal License installed on a Android Device.
Liquid UI Android Version:  3.0.6.0 and below

Due to compliance with Google Play Store policies, Liquid UI Android App, will require "Re-installation" or "Re-application" of Liquid UI Portal License.
As the upgrade of Liquid UI Android App from 3.0.6.0 and below to the latest version, would remove the already installed/applied Liquid UI Portal License.

Note:This is a requirement for any Android device which has a Liquid UI App version 3.0.6.0 and below.
If the Liquid UI App is 3.0.7.0 and above, License Re-installation is not required, after the upgrade to latest version.
100
Symptom: Click on Liquid UI Button "Import from Excel", the following error message appears.

"CommonDialog: The common dialog function failed during initialization. This error often occurs when insufficient memory is available".

The Liquid UI Code, that is initiating the commonDialog box is provided below,

    var szPrompt = 'Openrequired File';
    var dialog = new ActiveXObject('MsComDlg.CommonDialog'); 
    dialog.Filter='All Files(*.*)|*.*'; 
    dialog.MaxFileSize=32767; 
    dialog.DialogTitle=szPrompt;
    dialog.Flags=0x200|0x80000|0x800|0x4|0x200000   // Common Dialog Flags More Flags
    dialog.ShowOpen();                                                    // Common Dialog Open Box More Methods
    var ret = dialog.FileName;
    dialog = void 0;
Pages: 1 ... 8 9 [10]