Author Topic: Automating SAP Transactions with URL on Liquid UI Android & IOS  (Read 2437 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Automating SAP Transactions with URL on Liquid UI Android & IOS
« on: November 30, 2017, 07:47:39 AM »
Purpose
To automate Steps in the transaction using URL to minimize user interaction and increase the cost and time savings.

User Interface
Liquid UI for Android & IOS.

Automation via URL
Liquid UI for Android will parse the URL and perform require function depending on tcode, fields value and action definition. All the required information is included in the URL and pass to the SAP. The app requires sap login credentials.

Example:
Open link below in a web browser on your Android/IOS device which has Liquid UI installed.

<a href='sapr3://r3/target?gui=/H/SAPAPPSERVER/S/3600/G/SPACE&client=800&user=username&password=userpassword&language=EN&command=VA03;VBAK-VBELN=ordernumber;enter';>Display Sales Order[/url]
 
You will be navigated to specified SAP transaction with values assigned to fields and actions carried out as specified in the URL.

Note: On IOS you will see a pop up click on "open" on this popup to launch Liquid UI app.

Web URL Parameters
Liquid UI follows its own connection parameter in its URL as below.

sapr3:// :  Tell browser to open link through LUI app
//r3/target?gui : Specify the target server you want to connect
/H/Servername : Application server configuration
/M/Servername : Message server configuration
/S/3224 : Sapproxy Port configuration
Client : specifies Liquid UI Client number such as 800
User : needs to provide user name beside this parameter
Password : needs to provide password beside this parameter
Language : specify the language such as EN
Command : it can be transaction or system command

Example URLs:

Message Server:
<a href='sapr3://r3/target?gui=/M/SAPMSGSERVER/S/3600/G/SPACE&client=800&user=luiuser&password=luipassword&language=EN&command=VA03;enter'>Connect to SAP Message Server[/url]

Application Server
<a href='sapr3://r3/target?gui=/H/SAPAPPSERVER/S/3200&client=800&user=luiuser&password=luipassword&language=EN&command=VA03;enter'>Connect to SAP Application Server[/url]

Note: Liquid UI app will only get connected to SAP if the connection parameters in URL matches with the connection configured on Liquid UI app.

See Attachment for more information and screenshots