Author Topic: Use _notificationID to get unique device token  (Read 2620 times)

Leo Chu

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 16
    • View Profile
Use _notificationID to get unique device token
« on: December 01, 2017, 01:50:10 PM »
Liquid UI: Use _notificationID to get unique device token

This topic is to use system variable "_notificationID" to get unique Android or iOS device token via Liquid UI Server.
The purpose of using device token is specifically for push notification service.
For more detail, please contact Synactive.

Requirement:
Liquid UI Server:         Version 3.5.567.0 and above
Liquid UI on Android:   Version 2.0.33.0 and above
Liquid UI on iOS:         Version 2.0.26.0 and above


Step 1: Create user interface
clearscreen();

inputfield([1,0], {"name":"z_notificationID", "size":180, "readonly":true, "nolabel":true});



Step 2: Add logic to display the value from _notificationID
set("V[z_notificationID]", _notificationID);

println("=====>> _notificationID="+_notificationID+"<==");



Step 3: Connect Android or iOS device to the system via Liquid UI Server
When screen script gets load, device token will show in the field and Cornelius window.

Example of an Android device token:
f5R8ErhYdBI:APA91bG1Le-6i3ArojW0jEEvfU3eZCKeenCCCHe_yn-0iJRKaLeQV3AWM60ds5DLMTdrAtMGhq7sy_f5Cq04TdyE7hA1DPIWSSZi9hZckMTR2DyaVvFMZDMajthyznHpb3INQgkGNgaN

Example of an iOS device token:
3b1459128815b0f63109df1559d53e6d0757fc2d845f36018ae7021bb374b9c8

Note: _notificationID only works for Android and iOS device which installs required Liquid UI application
         The value of _notificationID will show "undefined" if it's connect from SAP GUI


Note: For more detail about using push notification service, please contact Synactive



See attachments for script example
« Last Edit: December 01, 2017, 01:59:17 PM by Leo Chu »