Author Topic: Liquid UI system variables "_page.exists" & "_client"  (Read 2078 times)

Sabir Mohammad

  • Administrator
  • Newbie
  • *****
  • Posts: 52
    • View Profile
Liquid UI system variables "_page.exists" & "_client"
« on: December 14, 2017, 09:07:45 AM »
Purpose:
_page.exists: It is used to verify whether a given tab or page is actually present in a transaction.
_client: It is used to find the SAP client and output it to the console window.

LiquidUI Code:
    Below code demonstrates the usage of above system variables on VA01 transaction.
---------------------------- SAPMV45A.E4001.sjs -------------------------------
if(_page.exists("Sales")){           //verifying whether the sales tab exists
       set("F[Sold-to party]", "1460"); //Assigning the value to the field
}
println(" SAP system client is:" + _client); //Displaying output on console window
« Last Edit: December 20, 2017, 04:04:21 PM by Rahul Gera »