Author Topic: LiquidUI - tablewidth Command  (Read 2392 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
LiquidUI - tablewidth Command
« on: December 28, 2017, 04:52:02 AM »
Purpose:
With tablewidth(), you can change the width of a table control in SAP. This command can be used only with native SAP tables.

Syntax:
tablewidth("T[Tablename]",X);

Properties:
     Tablename - name of a SAP table.
     X -  specified new width for SAP table

Note: "X" is replaced by the numerical value which specifies the new width for the table. The width specifies the number of characters.

Below example demonstrates the tablewidth command on "All items" table of "VA01" transaction.
Navigate to second screen of "VA01" transaction where we have "All tems" table and below enter below code in script file of this screen.

Liquid UI Code:
//////////////////////////// SAPMV45A.E4001.sjs //////////////////////////////

tablewidth("T[All items]", 50);

See attachment for screenshots