Author Topic: Liquid UI System Variables - _dynpro/_language/_program  (Read 2526 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Liquid UI System Variables - _dynpro/_language/_program
« on: January 11, 2018, 07:14:18 AM »
_dynpro
 A dynpro is the actual SAP program name. each SAP program is identified by a dynpro number. Examples of dynpro numbers are the following:
  0101
  0100
The dynpro is used with the language code and the program name to identify a given SAP screen.
The _dynpro variable is used to find which dynpro is currently being accessed or to perform operations based on a particular dynpro number.
In our example, we will simply find out which dynpro we are accessing and output that information to the console.
println("Dynpro>>"+_dynpro);

_language
The _language variable is used to return the current language code of a given implementations.
If users are operating in different languages, this variables is useful for  specifying the different files or different operations for different users based on language.
To find the current language and output that information to the console, we would write the following:
println("The language is >>"+_language);

_program
Everyday dynpro has a program name associated with it, as shown in the following examples:
  SAPMV45A
  SAPLSMTR_NAVIGATION
The _Program variable returns the program name for the current screen.
To return the current program number to the console, the following code can be used.
Println("program is >>"+_program);


Liquid UI Code:
////////////////////////////// SAPLSMTR_NAVIGATION.E0100.sjs //////////////////////////////

println("name of the current screen is  >>"+_program+"."+_language+""+_dynpro); // display output on console window

Name of the .sjs script files is made up of these variables.
you can see output similar to the name of script file currently in process on cornelius output window.
« Last Edit: January 16, 2018, 01:45:14 AM by sarvani.kusuri@guixt.com »