Author Topic: Domains Localvaluehelp  (Read 3184 times)

Benjamin Dasari

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 95
    • View Profile
Domains Localvaluehelp
« on: February 12, 2016, 05:29:34 PM »
Purpose:
The localvaluehelp command enables users to access help for possible input sets for SAP inputfields when you perform a right-click on the field in question. This command will function both on GuiXT and native SAP fields. The localvalue help command can be used only on inputfields.

Liquid UI Code:

Step 1:
// In GuiXT WS configuration file, 'guixt.sjs' make sure the domains path and the option below are set-
historyonrightbutton    = true;
domains = "C:\\guixt\\scripts";

Step 2:
// In the path specified in the configuration file place the file with the list of options-
// dom.E.CURRENCY.txt
ADP //Andoran peseta
AED //United Arab Emirates Dirham
AFA //Afghani
ALL //Albanian Lek
AMD //Armenian Dram
ANG //West Indian Guilder
AOK //Angolan Kwanza
BBD //Barbados Dollar

// dom.E.SHIPVIA.txt
A1 //Truck - Van
A2 //Truck - Flat Bed
A3 //Truck - Rail Deck
A4 //Truck - B-Train
A5 //Truck - Maxi
A6 //Truck - LTL
A7 //Cust PickUp Van
A8 //Cust PickUp Flat B
R1 //Rail - 50' Box car d
R3 //Rail - 52' High Cube
R4 //Rail - 60' High Cube
R5 //Rail - 60' Flat car
R6 //Rail - 66' Flat car

Step 3:
// User Interface
// SAPLSMTR_NAVIGATION.E0100.sjs

del("X[IMAGE_CONTAINER]");   // Delete ActiveX Container on SAP Easy Access
inputfield([1,1], "Currency", [1,15], {"name":"z_va0x_currency", "size":3});
localvaluehelp("F[Currency]", {"domain":"CURRENCY"});

inputfield([2,1], "Ship Via", [2,15],{ "name":"z_va0x_shipvia", "size":2});            
localvaluehelp("F[Ship Via]", {"domain":"SHIPVIA"});


See attachments for code samples!
« Last Edit: February 19, 2016, 07:23:11 PM by Benjamin Dasari »