Author Topic: Loading functions across sessions  (Read 2419 times)

rajesh.sabbineni

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 26
    • View Profile
Loading functions across sessions
« on: May 24, 2017, 04:37:09 PM »
Instead of calling functions from each individual screen, Synactive recommends to load functions in esession file so that functions can be used across all opened sessions.

Functions related to each process can be in one single file.
For example all the functions related to Va01, Va02, VA03 can be merged in to one single file (Functions_Va0x.sjs) and these functions can be called from any screen in the session.
 
Esession.sjs(session file)
load("FUNCTIONS_GENERIC.sjs");
load("FUNCTIONS_VA0X.sjs");

FUNCTIONS_GENERIC.sjs - Contains all the generic functions which are used across the scripts
FUNCTIONS_VA0X.sjs - Contains the functions related to va01, va02 and va03 transaction processes
 
« Last Edit: May 24, 2017, 04:40:04 PM by rajesh.sabbineni »