Author Topic: Horizontal and Vertical Scrolling on Listscreen using WS  (Read 1881 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Horizontal and Vertical Scrolling on Listscreen using WS
« on: September 20, 2017, 10:19:17 AM »
Below example explains the scrolling on listscreen in both horizontal and vertical directions with enter command using WS functions.

Horizontal scroll syntax:
enter("/hscrollto=x");
x - specifies number of columns to scroll

Vertical scroll syntax:
enter("/scrolltoline=y");
y - specifies the number of rows to scroll

Liquid UI Code:
/////////////////////////////////// RVKRED01.E0120.sjs ////////////////////////////////

pushbutton( [TOOLBAR], "Scroll Horizontal",{ "process": z_HorScroll }); // pushbutton to call z_HorScroll  function

pushbutton( [TOOLBAR], "Scroll Vertical",{ "process": z_VerScroll }); // pushbutton to call z_VerScroll function

function z_HorScroll(){ // function to horizontal scrolling on listscreen
     onscreen 'RVKRED01.0120'
          enter("/hscrollto=20");
}

function z_VerScroll (){// function to vertical scrolling on listscreen
     onscreen 'RVKRED01.0120'
          enter("/scrolltoline=10");
}