Author Topic: Old SAPGUI session locked sporadically when opening a new session.  (Read 3161 times)

umang@guixt.com

  • Administrator
  • Newbie
  • *****
  • Posts: 32
    • View Profile
Environment:
Liquid UI Server Version: 3.5.538.0 and below

Issue:
Old SAPGUI session locked sporadically when opening a new session.

Scenario where behavior is exposed
Use below script on SAP Easy Access Screen (SAPLSMTR_NAVIGATION.E0100.sjs)
clearscreen()
pushbutton([1,1],'Open session overview popup','/0',{'process':openSessionOverview});
pushbutton([4,1],'Open CICO','/ocico',{'process':openCICO});


function openSessionOverview() {
   
   onscreen 'SAPLSMTR_NAVIGATION.0100'
      enter('/o');
}

function openCICO(){
   onscreen 'SAPLCIC0.8100'
      enter("?");
}

When a /o screen is displayed from within the function execution (function openSessionOverview() in above example), discarding the popup, and immediately opening a new session either using the new session icon in SAPGUI
or via pushbutton click causes the old session to hang up


Resolution:
The issue is resolved in Liquid UI Server Version 3.5.539.0 and above.


« Last Edit: January 23, 2017, 02:00:06 PM by umang@guixt.com »