Liquid UI - Documentation - 17.10 Create tip for inputfield

17.10 Create tip for inputfield


Prerequisites


Purpose

The tip command is used to add tips to native SAP screen elements. It has a very simple syntax, taking the screen element as the first input and the tip you want to display as the second. In this article, we’ll show you how to add a tip to the input field to notify users about the accepted values for the field. 

Syntax

tip("F[Screen Element]","This is a tip");


User Interface

//Create this file inside your script folder for customizing Create Sales: Initial Screen. SAPMV45A.E0101.sjs

//Now, let's add the Liquid UI script to the above file and save it.

  1. Log into SAP and navigate to the VA01 transaction. Using the tip command, add the text “01, 02, or 03 only” as a tip to the input field Division in the Organizational Data Group box.
     
    // Add tip command to Division input field.
    tip("F[Division]","01,02, or 03 only");
     
  2. Now, refresh the screen and you can see a symbol next to the field. When the mouse hovers over it, the defined tip message will display, as shown below.
     

Can't find the answers you're looking for?