Liquid UI - Documentation - 17.06 Change the position of screen elements

17.06 Change the position of screen elements


Prerequisites


Purpose

In this article, you will learn how to use the pos command for changing the position of different input fields within the group box.


User Interface

//Create this file inside your script folder for customizing Create Sales Order: Initial Screen: SAPMV45A.E0101.sjs

//Now, let's start adding the Liquid UI script to the above file and save it.


Customization

Using the pos() you can change the position of the fields on the Create Sales Order screen.

  1. Logon to SAP, and navigate to the Create Sales Order: Initial Screen (VA01). As per the code, the specified field's position is changed, as shown below.
     
    //Changes the position of the following fields on the SAP screen.
    pos("F[Sales Organization]",[5,30]); 
    pos("F[Distribution Channel]",[6,33],{"value":true});
    pos("F[Sales Group]",[9,30],{"text":true});
    pos("F[Division]",{"field":"F[Sales Office]","offset":[0,30]});
     

Can't find the answers you're looking for?