Liquid UI - Documentation - 8.03 load()

8.03 load()


Purpose

With load(), you can load an external file. Once this file is loaded, anything included in the file will be available for global use in WS scripts.


Syntax

load("filename");

You can load files from the following locations:

Local directories

To load a file from a directory on your local machine:

load("filename");

Note: If the file is not in the same directory as the script file, you must specify the full path.

Network shares

To load a file from a shared directory on the network:

load("\\\\company.com\\directory\\filename");

SAP Web Repositories

To load a file from the SAP Web Repository (SAPWR), use the following syntax:

load("SAPWR:Z.GUIXT.SAPLSMTR_NAVIGATION.0100.sjs");

Note: Use the file command to give the file an alias if it exceeds the 30-character limitation on SAPWR file names.


Options

The load() command does not take any options.


Example

This example demonstrates the usage of load() command in converting the word file to PDF. The SAP screen will appear as follows:


Script

Open a script file and add the below code.

//ESESSION.sjs
// wsoffice.dll is required to be installed
load('wsoffice');

Script Details


Usage Details


Can't find the answers you're looking for?