Liquid UI - Documentation - 6.10 fieldsize()

6.10 fieldsize()


Purpose

With fieldsize(), you can fix the maximum number of characters entry in native SAP fields.

Note: Fieldsize() is restricted to standard SAP editable fields.


Syntax

fieldsize("F[Label name"],n);
Note: You cannot increase the size of a field to more than its original size. You can only reduce the size of a field.


Properties

  • Label name - name of the field.
  • n - field size.


Available Options

You can use the following options with the fieldsize:

"scrollable":".."

"scrollable":true - Enables scrolling in a field.


Options Detail

scrollable

  1. The scrollable option enables scrolling in a field. The scrollable option specifies if the resized field will or will not be scrollable by the user. For example, if you resize a field of 20 characters size to 10 characters, you can still enter 20 characters using the scrollable option.

  2. fieldsize("F[Material]",5,{"scrollable":true});
  3. Although the visible field length is still only five characters, we can enter up to the original field capacity and then scroll in the field to read every character.


Example

  • In the following example, we will resize the Material field on the MM01 screen. 
  • Launch SAP and navigate to the MM01 transaction.
  • The default screen appears as shown below:


Script

// 'SAPLMGMM.E0060.sjs'

fieldsize("F[Material]",5);

Can't find the answers you're looking for?