Liquid UI - Documentation - 3.3 Configuring SAP runtime environment for Web Server in config.sjs

3.3 Configuring SAP runtime environment for Web Server in config.sjs


The config.js file is where most of the actual Web Server configuration is performed. A typical config.js file will look as shown in the example below:

The parameters in the config.js file are as follows:

Server Parameters

The following parameters define the server information.

Note: Any parameters containing the key 'SSL' are used only if you are enabling SSL.
R3_SERVER_NAME

Specifies the SAP ERP connection string. Please see the Connection Strings section for more information about the definition of a connection string and the supported syntaxes. The syntax is shown below.

const R3_SERVER_NAME = "H/serverName";
DEF_WEBPORT_BASE

Defines the listening port used by the Web Server if you do not enable SSL. If you enable SSL, you will need to define the DEF_WEBPORTSSL_BASE entry defined below. The syntax is as follows.

const DEF_WEBPORT_BASE = "85";
Note: This port must be open on the firewall for Web Server to function correctly.
DEF_WEBPORT_IDX

Defines the index for the array that will contain the ports for the Web Server. It should be set to '0' by default as in this example. The syntax is shown below.

const DEF_WEBPORT_IDX	= "0";
USING_SSL

Specifies if you are or are not using SSL to connect to the Web Server. If this parameter is set to 'true', you must connect with SSL. Otherwise you will not connect with SSL.

const USING_SSL = false;
DEF_WEBPORTSSL_BASE

Defines the listening port used by the Web Server if you enable SSL. If you do not enable SSL, you will need to define the DEF_WEBPORT_BASE entry defined above. The syntax is as follows.

const DEF_WEBPORTSSL_BASE = "443";
Note: This port must be open on the firewall for Web Server to function correctly.
DEF_WEBPORTSSL_IDX

Defines the instance number for the Web Server. Multiple instances can run simultaneously on a single machine, so each instance must have a unique number.

const DEF_WEBPORTSSL_IDX  = "0";
DEF_SSL_PARAPHRASE

Defines the passphrase you select for SSL. The value is stored as a string and the syntax is as follows.

const DEF_SSL_PARAPHRASE  = "Alana888";
DEF_SSL_KEYFILE

Specifies the key file that is used by Web Server when SSL is enabled. This file is used to encrypt the SSL transmissions. It must be the file type 'key' and is typically stored in the C:\Program Files\Synactive Inc\GuiXTFuzion\cert directory. The syntax is shown below.

const DEF_SSL_KEYFILE     = "server.key";
DEF_SSL_CERTIFICATE

Specifies the security certificate that is used by Web Server when SSL is enabled. This file must be the file type 'cert' and is typically stored in the C:\Program Files\Synactive Inc\GuiXTFuzion\cert directory. The syntax is shown below.

const DEF_SSL_CERTIFICATE = "server.crt";

Client Parameters

The following parameters define the SAP client parameters if you are using Single Sign-on (SSO).

SSO_CLINUM

Specifies the three-digit SAP client number that will be used in SSO. The syntax is as follows.

const SSO_CLINUM	= "800";
SSO_LANG

Specifies the one-digit SAP language code for the client that will be used in SSO. The syntax is as follows.

const SSO_LANG		= "E";	

Web Parameters

The parameters listed below relate to the Web presentation in the browser and to the connection between the Web Server and SAP.

Note: You will not need to alter most of these from the default settings shown below.
HTML_TITLE

; Added from build 1.1.95.0. If you are upgrading from a version of Web Server earlier than 1.1.95.0, you must add this line to the config.js file. The syntax is as follows.

const HTML_TITLE	= "Synactive Web Server";
MAX_CONN_NUM

The maximum number of users who can concurrently connect to a single instance of Web Server. The default is 100.

const MAX_CONN_NUM	= 100;
SESSION_TIMEOUT

The time in seconds that the connection can be inactive before timing out. The default is 120 and the syntax is shown below.

const SESSION_TIMEOUT  = 120;
SESSIONIDKEY

This parameter is passed in an HTTP request from the client to the server. It is used to uniquely identify the user session at the server. The syntax is as follows.

const SESSIONIDKEY = "GWSessionID";
MODALIDKEY

This parameter is passed in an HTTP request from the client to the server. It is used to uniquely identify a connection at the server.

const MODALIDKEY	= "GWModalID";
REQMODALKEY

THis parameter is ...NEED CONTENT. It is used to ...NEED CONTENT.

const REQMODALKEY  = "REQMODAL";
NSESSIONS

Defines the maximum number of concurrent sessions supported. Currently, up to six concurrent sessions are supported by a single instance of Web Server.

const NSESSIONS  = 6;
NMODALS

Defines the maximum number of modals supported by a Server instance. Currently, up to six modals are supported by a single instance of Web Server.

const NMODALS  = 7;
OLETRACE

Used for tracing OLE calls. Set to ‘0’ by default. Set to ‘1’ to activate.

const OLETRACE = 0;
TIMESTAMP

Flag for activating timestamps. It is set to ‘0’ by default. To activate, change to ‘1’.

const TIMESTAMP  = 0;
PRINT_REQUEST_HEADERS

Set to ‘0’ by default, this parameter is used to print the HTTP request header. It is used primarily for debugging.

const PRINT_REQUEST_HEADERS = 0;
STORE_ALL_MESSAGES

Set to ‘false’ by default, this parameter is used to instruct Web Server if all messages should be stored or not.

const STORE_ALL_MESSAGES = false;
RELOAD_RETRY_MAX

Set to ‘3’ by default, this parameter instructs Web Server how many times it should try to reload data if a connection is lost.

const RELOAD_RETRY_MAX	= 3;
MENU_SENT_ONCE

Specifies that the root menus will only be sent once. Menus are strings as in the example.

const MENU_SENT_ONCE	= ["System", "Help"];
ENABLE_AUTOSAVE

Used to specify if the Auto-save feature is enabled or disabled. It is set to ‘0’ by default. Change to ‘1’ to enable the autosave feature.

const ENABLE_AUTOSAVE   = 0;
USE_CORNELIUS

Defines if the GuiXT Server is or is not using the GuiXT WS engine. Set this parameter to 'true' for a WS environment. Set it to 'false' if you are not using a WS environment. The syntax is shown below.

const USE_CORNELIUS	= true;
CORNELIUS_SCRIPT_LOCATION

Defines the location of the upload scripts to be accessed by the WS version of Web Server. Defined as a path as shown in the example below.

const CORNELIUS_SCRIPT_LOCATION	= "C:\TESTFILES\MyScripts";
MAX_UPLOAD_SIZE

Defines the maximum upload size for script files in XX format. Default is ‘0x20000’. Due to a round-up error, the actual script file may be only half of the listed size or 64KB.

const MAX_UPLOAD_SIZE	= 0x20000;
MAX_POST_SIZE

Defines the maximum file size in HTTP POST operations. Set to '0x2000' by default.

const MAX_POST_SIZE	= 0x2000;
HTML_FILEPATH

Defines the location of the HTML files that control the OLE_HTML_CONTROL. Formatted as path as shown in the following example.

const HTML_FILEPATH = "C:\guixt4web\saphtmls";
ENABLE_COMPRESSION

By default set to ‘false’. Specifies if the file will be compressed. Compression enables larger files to be sent, but can affect data quality. The syntax is as follows.

const ENABLE_COMPRESSION = false;
ENABLE_NTLM

Set to ‘false’ by default. Used during single-sign on to specify if NTLM is enabled. The syntax is shown below.

const ENABLE_NTLM = false;
g_usercatalog

Defines the user catalog in an array format.

g_usercatalog={};
g_usercatalog['user']

Sets the variable 'g_usercatalog' as the user password based on the user ID passed in.

g_usercatalog['user'] = 'password';

Gadget Flags

These flags apply to the Live Help feature built in Web Server. They should only be modified if you are so instructed by a Suynactive Sales or Support representative and are listed here for reference purposes only.

GADGETFLAGS

 

const GADGETFLAGS = {};
GADGETFLAGS.LIVEHELP

 

GADGETFLAGS.LIVEHELP	= 0x00000001;
GADGET_ENABLED

 

const GADGET_ENABLED	= GADGETFLAGS.LIVEHELP;

Client Flags

CLIENT_CAPS_ALL

This parameter is edited for client flags. It specifies the that when used, all the listed flags are included.

const CLIENT_CAPS_ALL	= CLIFLAGS.CLI_SYSTEMMENU|CLIFLAGS.CLI_TOOLBAR|CLIFLAGS.CLI_GADGET|CLIFLAGS.CLI_CNTXTMENU|CLIFLAGS.CLI_CMNDENTRY;
CLIENT_CAPS

Specifies that when used, it signifies the same thing as the 'const CLIENT_CAPS_ALL' parameter.

const CLIENT_CAPS	= CLIENT_CAPS_ALL;

Can't find the answers you're looking for?