Liquid UI - Documentation - 4.1.3.3 Editing webserver.js file

4.1.3.3 Editing webserver.js file


Once you have edited the PDF form in LiveCycle Designer, you must also edit the Web Server in order to enable PDF form functionality. To enable PDF functionality on the Liquid UI Web Server, please do the following.
  1. Stop the Web Server if it is running.
  2. Open the WebServer.js file. This is a configuration file for the GuiXT Web Server and it is located in the C:\Program Files\Synactive Inc\GuiXTFuzion directory. in this file, you must define the target transaction in SAP. In the WebServer.js file, locate the following section.
    function zws_perform_step1(request, response)
    {
    // we must be in easy access
    var R3 = this.session.R3connections[0];
    R3.GWSvrAction.svrHash = 'tc_zguixt';
    var res     = OnPost_guixt4web_request_cgi.call(this, request, response);
    return GWWebServer.FP_PRESERVE_HP;
    }
  3. Replace the 'tc_guixt' text with the desired transaction code. For example, if the target transaction is 'VA01', the new line would be 'tc_va01' as shown below:
    R3.GWSvrAction.svrHash = 'tc_va01';
  4. To define multiple transactions, separate them with the pipe symbol as in the following example.
    R3.GWSvrAction.svrHash = 'tc_va01 | tc_mm01 | tc_iw21';
  5. Save the changes and restart the Web Server.
  6. The Web Server is now configured and the transmission of the PDF form to the SAP ERP system should work as expected.

Can't find the answers you're looking for?