Liquid UI - Documentation - 4.02.06 Maintaining Master-data Structures

4.02.06 Maintaining Master-data Structures


Once the Master Records and Addendums have been defined as explained in the previous section, we need to maintain and populate the MasterData tables. Each MasterData object has a TCode and a Database structure, which will be explained in the following section.

  • TCode Structure: This defines the transaction code for the MasterData table. In our example, we will define this as being 'conf'. The code is shown below:
    g_WorkOrderAppDesc.MasterData.TCode = "conf";
  • Database Structure: The database structure defines the data table that is subsequently created. In our example, we are defining that the data table will have four elements - label, fieldname, displaywidth and fieldlength. The code is as follows:
    g_WorkOrderAppDesc.MasterData.Database = [{label:"Order Type",fieldname:"m_ordtype",fieldlength:4,displaywidth:15},{label:"Order Type Description",fieldname:"m_ordtypedesc",fieldlength:40,displaywidth:15}]; 

Can't find the answers you're looking for?