Liquid UI - Documentation - 4.02.11 Referencing Screen Elements

4.02.11 Referencing Screen Elements


All screen elements and screens in a Master Record - Addendum  structure are created as a part of a global array and are therefore indexed. When a screen element needs to be accessed, this action is performed due to the screen element's index. All of the generic code to create the screen templates resides in the SynR3.js file and so the corresponding indexes can be found in SynR3.js as well. It is sometimes difficult to locate the code in the SynR3.js file, and so Synactive has developed a custom functionality in order to return the indexes of all screen elements and transactions. Please note that functions are also considered as screen elements.

It is also possible to create new screen elements by assigning a new index to the element he or she wishes to create. For example, if we want to create a groupbox as a new screen element, we would use the following code:

SR3_arTransactions["wkdr"],.m_arScreenObjects[3][35] = {type:SCR_GROUPBOX,label:"Organizational Data",position:{row:0,col:0,height:6,width:82},fieldname:"z_sord_grpord"}; 

Users can also create additional elements of the following types:

  • Edit fields
  • Pushbuttons
  • Functions
  • Groupboxes
  • F-Keys
  • Toolbar pushbuttons
  • Table controls

Users can also edit and modify existing screen elements, depending on the attributes of those screen elements. Users can do  the following:

  • Modify pushbutton attributes
  • Change edit field attributes
  • Delete pushbuttons and edit fields 
  • Make edit fields read-only or invisible 
  • Make pushbuttons inactive 
  • Change the position of edit fields or pushbuttons 
  • Change the size of edit fields or pushbuttons 
  • Hide Onfkey

Can't find the answers you're looking for?