Liquid UI - Documentation - 5.13 tip()

5.13 tip()


Purpose

With the tip command, you can add a tooltip to the SAP elements. 

 

Note: The tip() applies only to the native SAP screen elements excluding Liquid UI elements. You can include a tooltip for the field label during its creation. 

Syntax

You can create a tip for screen elements with single line/ info text.

tip("F[ScreenElement]","This is a tip");

The tip command is available for the following elements.

ElementSyntax
Checkbox tip("C[checkbox_name]","Tip goes here");
Inputfield tip("F[field_name]","Tip goes here");
Pushbutton tip("P[pushbutton_name]","Tip goes here");
Radiobutton tip("R[radiobutton_name]","Tip goes here");
Groupbox tip("G[groupbox_name]","Tip goes here");
Table tip("T[table_name]","Tip goes here");


Options

The tip command does not take any options.


Example

The following examples demonstrate the usage of the tip() command for various screen elements:

 

Creating tips for checkbox

Steps

  1. Navigate to the Enter Other Goods Receipts: Initial Screen (MB1C).
  2. Create a script file, 'SAPMM07M.E0400.sjs', enter the following code, and save it.
  3. Execute the script file and refresh the screen.
  4. Hovering over the Print checkbox shows the tip Select checkbox to print.


    Liquid UI Script

    //Adds tip to Print checkbox
    tip("C[Print]","Select check box to print");
     


Creating tips for groupbox

Steps

  1. Navigate to the Create Sales Order: Initial Screen (VA01).
  2. Create a script file, 'SAPMV45A.E0101.sjs', enter the following code, and save it.
  3. Execute the script file and refresh the screen.
  4. Hover over the groupbox to see the tip Enter Sales Organization data.


    Liquid UI Script

    //Adds tip to the Print checkbox
    tip("G[Organizational Data]","Enter Sales Organization data");
     


Creating tip on a pushbutton

Steps

  1. Navigate to the Display Material(Initial screen) (MM03).
  2. Create script file, 'SAPLMGMM.E4004.sjs'. Enter the following code and execute the script file.
  3. When you mouse hover over the Basic data pushbutton, the tip appears as To view or enter long text about basic data


    Liquid UI Script

    //Adds tip to the push button 
    tip("P[Basic Data Text]", "To view or enter long text about basic data.");
      


Creating tip on radiobutton

Steps

  1. Navigate to the Enter Other Goods Receipts: Initial Screen (MB1C).
  2. Create a script file, 'SAPMM07M.E0400.sjs'. Enter the following code and execute the script file.
  3. Hovering over the Individual Slip radio button displays the tip This option is for individual slip.


    Liquid UI Script

    //Adds tip to the radio button 
    tip("R[Individual Slip]", "The option is for individual slip.");
     


Usage Details

  • Creating tip to input field

    We'll add a tip to the Order Type input field on the VA01 screen of SAP.

    //Adds tip to the Order Type input field 
    tip("F[Order Type]","This Field maintains the list of order types.");

    Mouse hover on the input field to see the tip, as shown below.

     

Can't find the answers you're looking for?