Liquid UI - Documentation - 8.08 rfcconnect-parameters

8.08 rfcconnect-parameters


Purpose

The rfcconnect command takes a number of parameters.

The rfcconnect command can be used to connect with either a Message Server or with an Application Server. In addition, the password can be either in plain text or encrypted. The example string above contains a number of parameters. Some of the parameters are used regardless of whether the RFC connection is being made to a message server or to an application server.

Note: If the password is encrypted, the plain text password will be replaced in the 'PASSWD' parameter by an encrypted string.


Common Parameters

The parameters common to both Message Server and Application Server are as follows:

IFDATABASE
The SAP ERP system that is currently connected. This parameter must be specified in the connection string in order for the connection to occur.
LANG
The default language to be used. 'E' is the language code for English.
CLIENT
The client to which the user is connecting. The standard SAP client is always '000', therefore it is very important to specify which client the user will connect to.
LCHECK
Boolean parameter that signifies if a logon check is performed at the time of opening. '0' indicates that no check will be performed; '1' specifies that a check will be performed.
USE_SAP_GUI
Specifies whether the SAP GUI is to be used or not in the relevant connection. Set to '0' if SAP GUI is not to be used; set to '1' if SAP GUI is to be utilized. By default it should be set to '0'.
USER
The username of the RFC user.
PASSWD
The password for the specified RFC user. This can be in two separate formats - either an unencrypted plain text string or an encrypted string.
GROUP
Specifies the SAP group to which the user belongs.


Message Server

The unique parameters for the Message Server are as follows:

MSHOST
Specifies the SAP Message Server to which the connection is being made.
R3NAME
Specifies the name of the SAP ERP system to which the connection is being made. This is important as the message server needs to know to which specific SAP ERP system it must pass the connection.

Note: If a message server is used, there are also additional parameters that must be included in the message server configuration file. Please see the GuiXT Server documentation for additional information. 

Connecting to Message Servers

If you want to connect to a message server, the string would look like the following example:

rfcconnect = [ "ifdatabase=XXX,mshost=message_server,r3name=sap_SYSTEM_NAME, group=group_name,lang=E,client=000,sysnr=00,lcheck=0, use_sapgui=0 ];
rfcuser="rfc_userName";
rfcpasswd="rfc_Password";


Application Server

The unique parameters for the application server are as follows:

ASHOST
Specifies the name of the target Server to which the connection is being made.
SYSNR
Specifies the system number of the target server to which the connection is being made. This is important as the application server needs to know to which specific SAP ERP system it must pass the connection.

Connecting to Application Servers

If you want to connect directly to an SAP application server, the rfcconnect statement would look like the example below:

rfcconnect = [ "ifdatabase=XXX,lang=E,client=100,ashost=system1,sysnr=00,lcheck=0,use_sapgui=0 ];
rfcuser="rfc_userName";
rfcpasswd="rfc_Password";


Single rfcconnect statement

If only a single server is to be the target, we can use a single rfcconnect command as shown in the following example:

rfcconnect ="ifdatabase=XXX,lang=E,client=100,ashost=system,sysnr=00,lcheck=0,use_sapgui=0";
rfcuser="user";
rfcpasswd="password";
    


rfcconnect arrays

If multiple servers are targeted, we can use a rfcconnect array as shown in the following example:

rfcconnect = [
	"ifdatabase=AD4,client=600, ashost=TEST4.SAMPLE.NET,sysnr=00",
	"ifdatabase=AD2,client=600, ashost=TEST04.SAMPLE.NET,sysnr=02",
	"ifdatabase=AT4,client=600, ashost=TEST6.SAMPLE.NET,sysnr=04",
	"ifdatabase=AT7,client=600, ashost=TEST06.SAMPLE.NET,sysnr=02"];
		

Note: The rfcconnect arrays statement supports only ifdatabase, client, ashost, and sysnr parameters.


Can't find the answers you're looking for?