Liquid UI - Documentation - 5.14 versionnumber()

5.14 versionnumber()


Purpose

The versionnumber() command mainly reduces web traffic for scripts hosted in SAP web repositories, FTP shared directories or HTTP web shares. It adds a version number to cached scripts from SAPWR. When the versionnumber() is updated, SAP refreshes its cache from SAPWR. Users can set this version number as needed, and each login loads scripts from the specified directory. 


Syntax

versionnumber("string", {"option":value});
 

Note: To use the versionnumber command, you must have one of the following files:

  • elogon.sjs
  • esession.sjs


Properties

  • String- name of the directory to cache scripts.


Available Option

You can use the following option with the versionnumber:

"systemid":".."

"systemid":"SAP_system_ID" - Add systemid in esession.sjs file.


Option Detail

systemid

  1. If you're using multiple SAP systems with the same name, you can specify a different system ID. This strengthens the cache directory name.

  2.  versionnumber("004",{"systemid":"TR1"});
  3. To change the system ID, go to the esession file path. Locate it under the Cornelius output window and assign the desired system ID.


Example

In the following example, we will demonstrate the versionnumber command in action.

  1. Add the following entry to the guixt.sjs file.

    directory1 = "SAPWR:Z.GUIXTSID";
  2. Set the RFC connection parameters in the guixt.sjs file.

    rfcuser = "XXXX";
    rfcpassword = "XXXX";
  3. Add version number to either elogon or esession files. In this case, we will use esession.sjs file and add the following entry:
    versionnumber("004");
     
     
  4. Now, when you log on to SAPGUI, WS will check the SAPWR directory and automatically download the latest script version into the specified folder.
  5. In this example, the script files are downloaded, as shown in the image.
     
     
  6. If the user logon to SAPGUI with a different system ID other than the one specified in the esession.sjs file, SAPWR won't cache any scripts into that folder by comparing the version number.

Change Version Number 

To change the version number in SAPWR, perform the following steps:

Step 1: Open ESESSION.SJS file and add the version number as follows.

versionnumber("005");

Step 2: Logon to SAPGUI and navigate to /nsmw0 transaction.

Step 3: Select Binary data for WebRFC applications option from Web object and hit Enter.

Step 4: Enter object name and hit execute.

For Example: Z.GUIXTSID1.*

Step 5: Click create object. Enter object name and description.

  • Object name would be the name followed by file name.
    Z.GUIXTSID1.ESESSION.SJS
  • Description will be file name.
    eSession

Step 6: Click Import to upload the new version number. Then upload the file and add the package name.

Step 7: Click Save, then you will see the changes, as shown in the image.

 

Can't find the answers you're looking for?