Liquid UI - Documentation - 4.02.07 Maintaining Menu Screens

4.02.07 Maintaining Menu Screens


It is possible to add menu screens to the application to enable easier navigation between screens. Typically, this menu will consist of an edit field and a number of pushbuttons, each of which will take the user to a different transaction. The edit field is used to manually enter a tcode instead of using the pushbuttons. If a menu screen is desired, it is necessary to first add a menu object. The code for this is as follows.

g_WorkOrderMenuDesc = {}; 

Once the menu object itself is created, the other elements should be added. These can be added using the Pushbutton, Caption and Edit objects previously introduced. Pushbuttons is an array object and can include a list of pushbuttons to be included on the screen. The fcode for each pushbutton should be used as the transaction code of the target screen. In the following example, we will add a caption, a list of pushbuttons and an edit field. The code is as follows:

g_WorkOrderMenuDesc.Caption = Work Order Application Menu"; 
g_WorkOrderMenuDesc.Pushbuttons = [{label:"@3W@Work Order",fcode:"swdr"},{label:"@3W@Add Parts",fcode:"iw32"},{label:"@3W@Confirm Time",fcode:"iw41"},];
g_WorkOrderMenuDesc.Edit = {label:"Selection",fieldname:"m_select"};

Can't find the answers you're looking for?