Liquid UI - Documentation - 1.02.01 Login Methods

1.02.01 Login Methods


This section covers the logon methodology that Offline uses to validate user credentials. Although Offline is capable of using single sign-on, it presently requires the user to input his or her Windows credentials in order to authenticate.

Offline supports three types of login methods that users can employ during the synchronization of data with SAP. These methods are as follows:

  • Standard logon
  • Windows authentication

To configure each of these types of logon, users would add the requisite lines to the config.js file. This file can usually be found in the following location:

C:\Program Files\Synactive Inc\GuiXTOffline\SynScript

In the following sections we will explain and demonstrate each type of Offline logon. We will also discuss the synchronization methods that can be used with each type of logon. 


Standard Logon

When standard logon is employed, users enter the logon credentials in the Offline logon screen, shown below:


 

The developer can configure the synchronization in either of two separate ways. It can either take the same login user name and password from the database file and log in to offline, or it can be configured to display a popup so that the user will have to enter the SAP user name and password every time synchronization occurs.

To configure standard logon, users must add the following line to the config.js file:

SR3SetAuthenticationMode(AUTH_MODE_STANDARD);


Windows authentication

When Windows authentication is used, the users must enter their Windows logon credentials into the Offline logon screen as shown below:


 

As in the case of the Standard logon, the developer can configure the synchronization in either of two separate ways. It can either take the same login user name and password from the Windows database file and log in to offline, or it can be configured to display a popup so that the user will have to enter the Windows user name and password every time synchronization occurs. This method provides an additional security layer for the Offline application.

To configure Windows authentication, users must add the following line to the config.js file:

SR3SetAuthenticationMode(AUTH_MODE_WINDOWS);

Can't find the answers you're looking for?