Liquid UI - Documentation - 6.01 Using the SynR3 Files

6.01 Using the SynR3 Files


In this section we will discuss the SynR3 files used by Offline. Topics covered are as follows:

 

SynR3.xml

The SynR3.xml file is used to define parameters to be read and used by the Offline service. A sample SynR3.xml file is shown below:


The SynR3.xml file contains the following parameters:

  • PoolSize: This specifies the subsequent memory allocation size (unit in pages) after the initial memory allocation. This value should only be changed if so instructed by a Synactive representative. Set to 256 by default.
  • InitialPoolSize: The memory size (unit in pages) that is initially allocated by Offline to launch the Offline service. Like PoolSize, this value should only be changed if a Synactive representative so instructs. Set to 2548 by default.
  • OutputTraceMessage: Defines how messages will be displayed in the Offline window. The default is '1'. Possible values are listed as follows:
    • 0: Messages are not displayed in Offline window.
    • 1: Error messages only are displayed in Offline window.
    • 2: Javascript errors are displayed in the Offline window.
    • 3: Javascript and C++ error messages are displayed in the Offline window.
    • 9: The code written to execute database operations such as insert or select will be written to console. o
    • 10: TimeStamp messages are displayed in the Offline window.
  • EnableExitConfirm: Boolean that specifies if the dialog asking users if they wish to exit Offline. If set to '1;, the dialog will appear; if set to '0', the dialog will not appear. The default is '0'.
  • EnableSaveLogon: Specifies if a dialog window asking is user wishes to save a log file will appear or not. If set to '0', the dialog will not appear; if set to '1', the dialog will appear. The default is '0'.
  • LogFilePath: Set by default to '/SynScript'. This parameter specifies where log files are to be stored.
  • MaxDebugWinLine: This parameter is placed in the code and specifies the maximum number of lines displayed by the Debug window. The recommended value is '1024'.
  • DatabaseFile: The default location of the Offline database file (SynR3.db). By default, this is \SynScript\, but can be changed here. If a user does change this, ensure that the filename 'SynR3.db' is included in the path.
  • LogToFile: Specifies if a logfile will be created. All information normally written to the Console will then be written to a log file instead, which wil automatically be generated and subsequently stored in the Offline folder. The resulting file will be automatically named using the following convention: SOLG_DATE_TIME_HOSTNAME_USERNAME.txt. The dates will be in the MMDDYYYY format, as in the following example: 05052011

     
    Each logfile is session-based. When a user opens a new session, a new logfile will be created. There is one difference betwen the console output and the logfile contents. The Console is limited to the amount of information that is contained in the buffer. However, the file has no such limitation and will contain all information related to the given session.  
    To initiate logging, please enter the following text line in the SynR3.xml file: <LogToFile>1</LogToFile>
     Restart Offline to initiate logging. To end logging, remove the line '<LogToFile>1</LogToFile>' from the SynR3.xml file.

  • Server Detection Threshold: Specifies the time in seconds for timing out if no server is detected. This enables users to control the interval prior to timing out if no server is detected. The default is set to 6000 seconds. To edit the server timeout, locate the following line in the SynR3.xml file: <SERVER_DETECT_THRESHOLD>6000</SERVER_DETCT_THRESHOLD>
     
    To change the threshold, simply alter the value in this entry and save your changes.


SynR3 Modifiable Variables

There are also some user-modifiable variables in the SynR3 file. This file should not be modified, as user changes can result in Offline performing improperly. However, there are three modifiable variables, which are as follows:

  • SR3_PASSWORD_CASESENSITIVE: A Boolean variable, set to 'true' by default. When true, it specifies that the Offline server login password will be case-sensitive. When set to 'false', the login password will be case-insensitive.
  • SR3_PROGRESS_INDICATOR_ENABLED: A Boolean value, it is set to 'true' by default. When true, the Mobile screen progress indicator for uploads and downloads is enabled. When false, the progress indicator is not enabled.
  • SR3_PROGRESS_INDICATOR_MODULO: This parameter controls the frequency of displaying Progress indicator on the Mobile screen. Set to '1' by default, the higher the number chosen, the more frequent the display frequency. If set to '1', every record's progress is displayed. If set to '10', then only one of every ten records will be displayed, and so on.

Can't find the answers you're looking for?