Liquid UI - Documentation - 6.04.05.04 JListControl

6.04.05.04 JListControl


The JLIstControl is used to create and manipulate Offline screen list controls. It constructs a new list control using the caption, row number and position information. The syntax is as follows:

JListControl(strCaption,iRowNum,iRow,iLeft,iBottom,iRight); 

An example of a new JListControl is shown below:

objListControl = new JListControl(strCaption,iRowNum,iRow,iLeft,iBottom,iRight);

The JListControl is associated with the following methods.

SetColumnAttributes

This method sets the attributes for the list control's columns, including title, field names, length, type, width, and state. The syntax is as follows:

JListControl.SetColumnAttributes(strTitle,strFieldName,iLength,iType,iWidth,iState); 

An example is as follows:

objListControl.SetColumnAttributes(strTitle,strFieldName,iLength,iType,iWidth,iState);


SetCellData

This method sets the values for the table cells. Values set are the row, column and actual value contained in the cell. The syntax is as follows:

JListControl.SetCellData(row,col,strValue);

An example is as follows:

objListCon

 

GetCellData

This method is used to get the data values from a given cell in a list control. There are two possible syntaxes - using the row and column values or using the row and field name. These are both shown below:

JListControl.GetCellData(iRow,iCol);
JListControl.GetCellData(iRow,strFieldName);

Examples are as follows:

strValue = objListControl.GetCellData(1,2); 
strValue = objListControl.GetCellData(1,"field_name");


GetColNumber

This method returns the number of columns in a given table control. The syntax is as follows:

JListControl.GetColNumber( ); 
trol.SetCellData(1,2,"value");


SetRowRange

This method defines how many rows of a given table should display on a screen. The syntax is as follows:

JListControl.GetColFieldName(iStartRow,iEndRow);

An example is below:

objListControl.SetRowRange(1,10);


GetSelectedRow

This method returns the selected row in a list control. The syntax is as follows:

JTableControl.IsRowSelected( ); 

An example is shown below:

bSelected = objTableControl.IsRowSelected(); 


RemoveControl

This method removes a given list control from a screen. The syntax is as follows:

JListControl.RemoveControl( );

An example is shown below:

objListControl.RemoveControl( ); 

Can't find the answers you're looking for?