Liquid UI - Documentation - 5.04 Dropdownlist Properties

5.04 Dropdownlist Properties


With dropdownlist properties, you can view and change the properties of the dropdownlist. For creating a dropdownlist, you need set command and dropdownlist command.

  1. In this article, we will be explaining you the dropdownlist properties with an example of editfield replacement, running on Create Sales Order screen. The tcode is VA01. Navigate to VA01 transaction and make sure to activate Liquid UI button. The VA01 screen will appear as following:
     
  2. As shown in above figure, Order Type has an editfield. We can customize the screen by replacing the editfield with Dropdownlist.
  3. To initiate the process, delete the editfield of Order Type. The screen now appears as following:
     
     
    //Delete the editfield of Order Type
    del("F[Order Type]",{"value":true});
    del("#[2,29]",{"text":true});
  4. Perform right click on the WYSIWYG editor. The Create New Element window will popup. You will get a tooltip when you place the cursor on the dropdownlist. It will display the fields required for UI control creation and provides you with the default values of dropdownlist:
    • Height - 1
    • Width - 30
     
  5. For creating the dropdownlist control, follow the below steps:

    1. Right click on the screen to view the Create New Element window.
    2. Enter the Row coordinates of the screen.
    3. Enter the Column coordinates of the screen.
    4. Specify the Width for the dropdownlist.
    5. Provide the Text to add the label name for the dropdownlist menu.
    6. Click on dropdownlist to create the dropdownlist on the screen.
      • Height - 1
      • Width - 30
     
     
    //Set the values to the dropdownlist
    set("V[mylist]","=--- Select Order Type---;AA=Promotion Order;CMR=Standard Order;AEBO=AEBO Order;");
    //Create the dropdownlist for the Order Type field
    dropdownlist([2,17],"mylist",{"refer":"F[Order Type]","width":30,"process":test_dropdown}); 
  6. Double click on the Dropdownlist to select the Dropdownlist properties. A popup window will appear as following:
     
  7. To know more about the dropdownlist, click here.

The Property window is categorized into three sections:

  1. Original SAP Information: The information provided in this section is not editable. Every Dropdownlist has following properties:
    • Control: Specifies the screen element.
    • Position: Specifies the onscreen coordinates of Dropdownlist. This is a read-only field - it is not user-modifiable.
    • Width: Specifies the width of Dropdownlist in pixels.
    • Height: Specifies the height of the Dropdownlist in pixels.
    • Size: Specifies the coordinates of the Dropdownlist in [Width, Height].
    • Text: Specifies the onscreen label name of the Dropdownlist.
    • Tech Name: This field maintains the GuiXT technical name of the Dropdownlist.
    • Field Name: This field specifies the field name of the Dropdownlist. The field name for the Dropdownlist is F[Text].
      Note: Original SAP Information parameters are non-editable.
  2. Enhancements: To edit the Dropdownlist property, you can edit with Enhancements. It includes the following options:
    • Row: Specifies the onscreen row number of the Dropdownlist.
    • Column: Specifies the onscreen column number of the Dropdownlist.
    • Width: Specifies the width of Dropdownlist in pixels.
    • Height: Specifies the height of the Dropdownlist in pixels.
    • Text: Specifies the onscreen label name of the Dropdownlist.
    • Relative To: Specifies if the element is being positioned relative to another screen element.
    • Read-only: Pre-select the Read-only option to make the Dropdownlist as not editable.
    • Turn into no-dropdown: Select this option to disable the Dropdownlist menu and make it as simple editfield.
  3. Overwrite Default: It includes the following options to enable the overwriting of Dropdownlist value.
    • isOverWrite: Mark this option to overwrite the dropdownlist with the specific value.
    • Overwrite with default: Specify any value in this option to display the value by default

Can't find the answers you're looking for?