Liquid UI - Documentation - 3.7 Configuring SSL in Web Server

3.7 Configuring SSL in Web Server


You can configure the Web Server to connect securely using SSL, enabling users to access the Liquid UI Web Server securely - the SAP application server itself communicates with the liquid UI Web Server via DIAG so no encryption is required. There are two separate scenarios where SSL can be implemented, as follows:

  • Single Server (Standalone)
  • Multiple Servers (Load Balancing)

Single Server (Standalone)

To configure SSL on a single, or standalone, Web Server, please do the following.

  1. Open the 'config.js' file in the 'C:\Program Files\Synactive Inc\GuiXTFuzion\' directory.

  2. Verify that the following parameters are present.

    • const USING_SSL = false;
    • const DEF_WEBPORTSSL_BASE = "443";
    • const DEF_WEBPORTSSL_IDX = "0";
    • const DEF_SSL_PARAPHRASE = "Alan888";
    • const DEF_SSL_KEYFILE = "server.key";
    • const DEF_SSL_CERTIFICATe = "server.crt";
  3. Change the value for 'USING_SSL' from 'false' to 'true'.

  4. Change the value for 'DEF_SSL_PARAPHRASE' from 'Alana888' to a custom phrase of your own invention.

  5. Edit the keyfile and certificate entries. These entries refer to the 'server.key' and 'server.crt' files located in the 'C:\Program Files\Synactive Inc\GuiXTFuxzion\' directory.

    Note: You must replace these default files with a valid certificate and key for SSL to function. You can either purchase a certificate from a provider such as Verisign or generate a self-signed certificate.
  6. Save your changes and launch your preferred Web browser.

  7. Type the following URL into the browser address bar.

    https://localhost/guixt4web/logon.gsp
  8. You will see the Web Server login screen. Enter your login and password and you are now logged into SAP via the Web Server.

Multiple Servers (Load Balancing)

To add SSL to a load-balancing environment using the Dispatcher, please do the following. For additional information on load-balancing, please see the Dispatcher section of this document.

  1. Go to the 'C:\Program Files\Synactive Inc\GuiXTFuzion\' and open the 'dispatcher.js' file.

  2. Verify that the following parameters are present. If any of these are not present, add it.

    • const USING_SSL = 0;
    • const LISTEN_PORT = 80;
    • const MAX_CLIENT = 100;
    • const CHECK_CYCLE = 10000;
  3. Change the 'USING_SSL' parameter from '0' to '1' if it is not already so configured.

  4. Open the 'config.js' file.

  5. Verify that the following parameters are present. If any of these are not present, add it.

    • const USING_SSL = 0;
    • const LISTEN_PORT = 80;
    • const MAX_CLIENT = 100;
    • const CHECK_CYCLE = 10000;
  6. Change the 'USING_SSL' parameter from 'false' to 'true' if it is not already so configured.

  7. Change the value for 'DEF_SSL_PARAPHRASE' from 'Alana888' to a custom phrase of your own invention.

  8. Edit the keyfile and certificate entries. These entries refer to the 'server.key' and 'server.crt' files located in the 'C:\Program Files\Synactive Inc\GuiXTFuxzion\' directory.

    Note: You must replace these default files with a valid certificate and key for SSL to function. You can either purchase a certificate from a provider such as Verisign or generate a self-signed certificate.
  9. Type the following URL into the browser address bar.

    https://localhost/guixt4web/logon.gsp
  10. You will see the Web Server login screen. Enter your login and password and you are now logged into SAP via the Web Server.


Can't find the answers you're looking for?