Liquid UI - Documentation - 1.1 Workbench Overview

1.1 Workbench Overview


Liquid UI Workbench is a development tool built to use with the WS Platform. This tool works in conjunction with the new WS Office extension. It enables SAP users to create custom scripts, which can access the power of Microsoft Office applications and Adobe PDF forms. In other words, Workbench enables users to perform the application integration that is enabled by the WS Office product. The added functionality includes the ability to perform the following actions:

  • Migrating bulk data from Excel to SAP
  • Migrating data from SAP to Excel
  • Migrating data from PDF forms

 

The scripts generated from Workbench can be used on the WS platform and its extensions, including WS Office to access the familiar methods and properties of VBA to accomplish full ActiveX integration. WS Office can dynamically read and edit a live Excel spreadsheet and employs the properties of the Synactive Web Server to accept POST-ed PDF forms. The web service allows you to log on to the Web Server, navigate to the desired transaction and then transfer the values from the PDF form to the applicable SAP transaction screen.

Workbench also supplies the ability to record and generate scripts to use with SAP GUI and WebUI transactions, server-side and client-side scripts for uploading and downloading data to SAP. Here, the data can be from distinct sources such as Offline solutions, scripts that are ready to use with the Access smartphone client, and scripts for performing bulk data migration both to and from Excel spreadsheets and PDF forms.

When these scripts are used with the WS Office extension, SAP users can use tools such as Microsoft Excel spreadsheets and PDF forms to quickly and easily upload data to SAP. With Workbench, users can now record a transaction or series of screens in SAP, map SAP fields to an Excel spreadsheet, generate the resulting Excel spreadsheet or PDF form and finally generate a script that will perform a bulk upload of user-entered data to SAP. Additionally,  Workbench can be used to generate scripts, which can be used to create forms in SAP GUI and the Offline and Access solutions, thus eliminating the necessity of navigating through multiple screens in SAP to perform data entry. In the case of Excel and PDF data migration, a single button will perform the data transfers, and users can then create and edit data within the surroundings of the Workbench and PDF environments. And with Workbench, users can record and generate runtime scripts to process these bulk data migrations.

Workbench is built on the same WS platform that drives all of Synactive's next-generation solutions so you can leverage that power to build scripts that will function effortlessly on any of the WS family of products. However, using Workbench in connection with the WS Office extension enables you to perform bulk data uploads as well as leverage functionality built into the Windows platform itself. This document will explain how to use the Workbench to record transactions in SAP, generate the custom scripts, and execute those scripts on the interfaces where you wish to use them.

Note: This document is based on the 1.0.15.0 release of Workbench.

Functionality

Using Workbench, you can create scripts that enable SAP users to access the power of Microsoft applications and Adobe PDF forms. A virtue of the Workbench is that a script created for one interface will be used for others as well. Record once and deploy many times. The Workbench's feature set includes the following.

    • Record scripts from a wide variety of SAP screens, transactions, and processes.
    • Edit previously recorded transactions and specify which aspects will and will not be included in the final script generated. Editable selections include the following:
      • Specify if the field will or will not be part of the generated script.
      • Change the onscreen label of screen elements.
      • View the technical name of the screen element.
      • Change the field length.
      • Select if table columns are read-only or editable.
      • View the table column numbers.
      • View the user-created Liquid UI field name.
      • View table indexes.
      • Edit field offsets.
      • Set default values.
    • Perform error handling and correction in Excel spreadsheets.
    • Save recordings as proprietary GVL files, which can be used to construct custom processes and transactions.
    • Generate custom scripts for users working on any of Synactive's interfaces, including Liquid UI for iOS, Liquid UI for SAPGUI, WebUI (including Microsoft SharePoint), Liquid UIServer, Liquid UI Offline, Liquid UI Access, and Liquid UI Mobile solutions.
    • Create scripts to perform bulk data transfers from Microsoft Excel to SAP and vice-versa. You can include error handling in the finished script to handle any problems, which may occur due to erroneous data entry.
    • Create scripts to perform bulk data migration from PDF forms or HTML web pages to SAP.
    • Validate user-entered data.
    • Support for Japanese character entries.
    • Architecture and Deployment
    • Transaction Types

Can't find the answers you're looking for?