Liquid UI - Documentation - 6.15 link()

6.15 link()


Purpose

With link(), you can link variables to entry fields. In contrast to Set, the variable is updated automatically with the value entered by the user. For example, you can use it when you fill the fields automatically, and assume that the user might enter some of the fields manually as well.


Syntax

link("variable","field");


Properties

  • field - name of the inputfield
  • variable - name of the variable to store the value

Note: You can either set and get the values from a variable, inputfield, or table cells. For example you can consider any format from the following:

link("F[entry field]","V[varname]"); The variable sets the entry field and receives newly entered values.
link("V[varname]","F[entry field]"); The variable gets the entry field value and receives newly entered values.
link("cell[table,column,row]","V[varname]"); The variable sets the table cell and receives newly entered values.
link("V[varname]","cell[table,column,row]"); The variable gets the table cell value and receives newly entered values.


Options

The link command does not take any options.


Example

In this example, link() command is used to link the dates of two different inputfields and in addition, the variable saves the date before input.

Script Details:

SAPMV45A.E4001.sjs

set("F[Pricing date]", "&[PO date]");
link("V[date]","F[Pricing date]");
onUIEvents['enter'] = linkdate;
onUIEvents['?'] = linkdate;
function linkdate()
{
println("==============================");
println("The pricing date is linked to PO date== "+ date);
println("==============================");
}

Can't find the answers you're looking for?