Liquid UI - Documentation - 5.4 Simplified SAP screens

5.4 Simplified SAP screens


Prerequisites


Purpose

With Liquid UI SDK, you can customize SAP screens easily without writing a line of code and can access them on your client devices like PC , iOS and Android using Liquid UI Server. Designer helps you to build your user interface as per your requirement and the changes made in the designer are reflected on SAP.

Note: To learn more about SAP customization using Liquid UI SDK in a simple way.


User Interface

In this scenario, you can view customized MM01 transaction accessed from Liquid UI Server to various devices as shown below:

  1. Navigate to Create Material(MM01) screen and execute the Liquid UI Script to view the customized SAP screen in your Liquid UI Server.
  2. You can access the customized SAP screens in your client PC from Liquid UI Server as shown below:
     
  3. You can access the customized SAP screens in your iOS device from Liquid UI Server as shown below:
     
  4. You can access the customized SAP screens in your Android device from Liquid UI Server as shown below:
     

Note: You need to configure Liquid UI Server and Client to access customized screens in your client device.


Liquid UI Script

SAPLMGMM.E0060.sjs

pushbutton([22,54],"@2L@Create Material",{"process":mm01_create_material});
del("F[Change Number]");
pos("F[Industry sector]",[3,51]);
pos("F[Material Type]",[4,51]);
del("G[Copy from...]");
del("F[Material]");
radiobutton([7,47],"Plant 1000",{"name":"z_mm01_plant","value":1000});
box([11,46],[15,90],"Basic Data");
box([6,46],[10,90],"Organizational Data");
box([16,46],[20,90],"MRP Data");
box([2,44],[23,92],"");
inputfield([8,48],"Stor.Loc",[8,58],{"name":"z_mm01_storloc","size":4, "required":true});
inputfield([12,48],"Description", [12,60],{"name":"z_mm01_desc","size":25});
radiobutton([7,78],"Plant 3000",{"name":"z_mm01_plant","value":3000});
inputfield([14,48],"Mat Grp",[14,60],{"name":"z_mm01_matgrp","size":3});
inputfield([13,48],[13,60],{"name":"z_mm01_buom","size":2});
checkbox([19,49],"BulkMaterial",{"name":"z_mm01_blkmat"});
inputfield([17,48],"Mrp Type",[17,60],{"name":"z_mm01_mrptype","size":3});
radiobutton([7,63],"Plant 2000",{"name":"z_mm01_plant","value":2000});
function mm01_create_material(){
// Create Material (Initial Screen)
onscreen 'SAPLMGMM.0060'
enter('/5');
// Create Material (Initial Screen)
onscreen 'SAPLMGMM.0070'
set('Cell[Table,0,1]','X');
set('Cell[Table,0,4]','X');
set('Cell[Table,0,6]','X');
set('Cell[Table,0,12]','X');
set('Cell[Table,0,13]','X');
set('Cell[Table,0,14]','X');
enter('/6');
// Create Material (Initial Screen) onscreen 'SAPLMGMM.0080'
set('F[Plant]','&V[z_mm01_plant]'); set('F[Stor. Location]','&V[z_mm01_storloc]'); set('F[Sales Org.]','1000'); set('F[Distr. Channel]','10'); enter(); // Create Material 68999 (Finished product) onscreen 'SAPLMGMM.4004' set('F[MAKT-MAKTX]', '&V[z_mm01_desc]'); set('F[Base Unit of Measure]','&V[z_mm01_buom]'); set('F[Material Group]','&V[z_mm01_matgrp]'); enter('=SP04'); // Create Material 68999 (Finished product) onscreen 'SAPLMGMM.4000' set('cell[TABLE,5,1]','1'); enter('=SP06'); // Create Material 68999 (Finished product) onscreen 'SAPLMGMM.4000'
set('F[Trans. Grp]','0001'); set('F[LoadingGrp]','0001'); enter('=SP12'); // Create Material 68999 (Finished product) onscreen 'SAPLMGMM.4000' set('F[MRP Type]','&V[z_mm01_mrptype]'); enter('=SP13'); // Create Material 68999 (Finished product) onscreen 'SAPLMGMM.4000' if (z_mm01_blkmat=='X') set('C[Bulk Material]','X'); set('F[SchedMargin key]','000'); enter('=SP14'); // Create Material 68999 (Finished product) onscreen 'SAPLMGMM.4000' set('F[Availability check]','01'); set("V[z_mm01*]",''); enter('/11');
}

Can't find the answers you're looking for?