Liquid UI - Documentation - 3.5 Connecting Web Server to SAP Server

3.5 Connecting Web Server to SAP Server


In order to connect to a SAP ERP system, Liquid UI Web Server needs to know where that server is located. Connection strings specify the SAP ERP system to which the RFC user will connect. Connection strings can be used either to point directly to a SAP ERP system or to point to a back-end system using a message server when load-balancing is being utilized. They can be defined in the config.js file. This is specified by means of connection strings, which are entered into the SAP Router field in a SAP connection. Connection strings can be entered in a variety of formats. These formats are as follows:

Note: In all conection strings below, the [serverName] value may be either an IP address or a system name.
/H/[serverName]

This connection string is used when there is a single server to connect to. The value that replaces the [serverName] can be either a GuiXT Server or a SAP application Server. If our server is named 'Coffee', the string would appear as follows.

/H/Coffee
/H/[serverName]/G/[groupName]

This format is used when you are connecting to a single server, but when there are more than one user group on that server. So if we are still using the 'Roast' group on the 'Coffee' server, the connection string would appear as shown below.

/H/Coffee/G/ROAST
[serverName]:[portNumber]

This format is used when you are connecting to a single server and you wish to specify the port that is to be used. So if we are using port number 3600 on the 'Coffee' server, the connection string would appear as shown below.

Coffee:3600
/H/[serverName]/S/[messageServerName]

This format is used when you are connecting to a single server, but when there are more than one user group on that server. So if we are still using the 'Roast' group on the 'Coffee' server, the connection string would appear as shown below.

/H/Coffee/G/ROAST
/H/[serverName]/S/[messageServerName]/G/[groupName]

This format is used when you are connecting to a specific server through a message server and when there are more than one user group on that server. So if we are using a mesasge server called 'Decaf' to connect to our 'Coffee' server and we are in the group 'Roast', the connection string would appear as shown below.

/H/Coffee/S/Decaf/G/Roast

Connection strings can be used either to point directly to a SAP ERP system or to point to a back-end system using a message server when load-balancing is being utilized as shown in the examples above that specify a message server. For more information about load-balancing, please see the Load Balancing section in this document.

If you are using the rfcconnect command, you can use this command to directly enter a connection string. A typical rfcconnect string will look as shown in the following example:

rfcconnect = "SYSNR=00 IFDATABASE=TRX LANG=E CLIENT=800 ASHOST=juneau  SYSNR=00 LCHECK=0 USE_SAPGUI=0 USER=ayam PASSWD=x05y9a787q/rmAYe7CqiUmcsXVyK3N427ummcQ04LPs=" ;
Note: In this example, we are using an encrypted RFC password. If you are not using an encrupted password, it will be in plain text.

In addition to a single rfcconnect entry, it is also possible to enter an array that contains multiple rfcconnect strings. Such an array would look as in the following example:

rfcconnect = [ "IFDATABASE=GD4 CLIENT=600 ASHOST=HMLUSDA4.SAMPLE.NET SYSNR=00",
"IFDATABASE=GD2 CLIENT=600 ASHOST=SAMPLE4.SAMPLE.NET SYSNR=02",
"IFDATABASE=GT4 CLIENT=600 ASHOST=SAMPLE6.SAMPLE.NET SYSNR=04",
"IFDATABASE=TRX CLIENT=800 ASHOST=SAMPLE1 SYSNR=00",
"IFDATABASE=GT7 CLIENT=600 ASHOST=SAMPLE6.SAMPLE.NET SYSNR=02"];

Message Server Parameters

Message strings can be used to connect with either a Message Server or an Application Server. The connection strings above contains a number of parameters. When used with the rfcconnect command to connect to either a message server or an application server, these parameters are specified with variable names in the string or array format as demonstrated above. Some of the parameters are used regardless of whether the RFC connection is being made to a message server or to an application server. However, there are certain unique parameters that are specific to a Message Server or to an Application Server. thse parameters are explained in the following section.

MSHOST

This parameter specifies the name fo the message server to which you are connecting.

R3NAME

This parameter defines the name of the SAP Application Server to which you will connect. This is important as the message server needs to know the specific SAP application server to which the connection will be passed.

GROUP

This parameter defines the group to which your user ID belongs. Group membership is used as a parameter to determine which SAP Application Servers you will access.

Application Server Parameters

The parameters specific to an application server are explained in the following section.

ASHOST

This parameter specifies the name of the SAP application server being used for the connection.

SYSNR

This parameter defines the system number of the SAP instance to which the user will connect. There can be multiple instances in a single connection. The system number is typically a two-digit number and can be obtained from the SAP ERP system properties.

GROUP

This parameter defines the group to which your user ID belongs. Group membership is used as a parameter to determine which SAP Application Servers you will access.

Common Server Parameters

The parameters that are common to both a message server and to an application server are explained in the following section.

IFDATABASE

This parameter specifies the SAP ERP system that is currently connected. This parameter must be specified in the connection string in order for the connection to occur.

LANG

This parameter defines the default language to be used. 'E' is the language code for English.. The language code is typically a single alphabetic character and can be obtained from the SAP ERP system properties.

CLIENT

This parameter defines the client to which tyou will be connecting. The standard SAP client is always '000', therefore it is very important to specify which client the user will connect to.

LCHECK

This parameter is a Boolean parameter that signifies if a logon check is performed at time of opening. '0' indicates that no check will be performed; '1' specifies that a check will be performed.

USE_SAPGUI

This parameter specifies whether the SAP GUI is to be used or not in the relevant connection. Set to '0' if SAP GUI is not to be used; set to '1' if SAP GUI is to be utilized. By default it should be set to '0'.

USER

This parameter contains the user name for the specified RFC user ID.

PASSWORD

This parameter contains the encrypted password for the specified RFC user ID.

CLIENT

This parameter defines the group to which your user ID belongs. Group membership is used as a parameter to determine which SAP Application Servers you will access.

CLIENT

This parameter defines the group to which your user ID belongs. Group membership is used as a parameter to determine which SAP Application Servers you will access.


Can't find the answers you're looking for?