Liquid UI - Documentation - 6.04.05.02 JControl

6.04.05.02 JControl


The JControl object is used to define screen objects in Offline. The arguments passed to the constructor are the screen object, the field name and the field type. The syntax for creating a JControl is as follows:

JControl(objScreen,strFieldName,iFieldType); 

An example of a JControl object is shown below:

objControl  = new JControl(objScreen,strFieldName,iFieldType); 


The methods associated with the JControl object are as follows:

SetFocus

This method sets the caption for a given screen. The syntax is as follows:

JScreen.RemoveTopScreen(strCaption,strDynProName,strDynProNumber); 

An example is shown below:

objScreen.SetFocus("Create Sales Order","SAPMV45A","0100" ); 


GetFocusedRow

This method gets the row position for the control. The syntax is as follows:

JScreen.GetFocusedRow( );

An example is shown below:

iRow = objScreen.GetFocusedRow( ); 


GetFocusedCol

This method gets the column position for the control. The syntax is as follows:

JScreen.GetFocusedCol( ); 

An example is shown below:

iCol = objScreen.GetFocusedCol( );

Can't find the answers you're looking for?