Liquid UI - Documentation - 5.13 Text Properties

5.13 Text Properties


With Text properties, you can view and change the properties of the Text. For creating text, you need Text command. This command also helps in changing the name of the SAP elements like checkbox, context menus, inputfield, pushbutton, radiobutton, and tab.

  1. In this article, we will be explaining you the Text properties with a text example, running on Create PM Notification screen. The tcode is IW21. Navigate to IW21 transaction and make sure to activate Liquid UI button. The IW21 screen will appear as following:
     
  2. Right-Click to place the text on the SAP screen, then a Create New Element window will popup. You will get a tooltip when you place the cursor on the Text. It will display the fields required for UI control creation and provides you with the default values of Text:
    • Height - 1
    • Width - 7
    • Text - Text
     
  3. For creating the Text control, follow the below steps:

    1. Right-Click on the screen to view the Create New Element window.
    2. Enter the Row coordinates of the screen.
    3. Enter the Column coordinates of the screen.
    4. Specify the Width for the Text.
    5. Provide the Text to add the label name of the Text.
    6. Click on Text to create the Text on the screen.
     
  4. You can view the Text created as "Enter Notification Information" on top of the screen.
     
    //Create a Text as Enter Notification Information
    Text([0,1],"Enter Notification Information",{"size":20});
  5. To open the Text properties window, double click on the Text. A popup window will appear as shown below:
     
  6. Under Properties, you can edit the Text field as required. To change the position of the Text, enter the row and column coordinates of the Text. You can also edit the script in the script editor.
  7. The Property window is categorized into four sections:
  1. Original SAP Information: The information provided in this section is not editable. Every Text has following properties:
    • Control: Specifies the screen element.
    • Position: Specifies the onscreen coordinates of Text. This is a read-only field - it is not user-modifiable.
    • Width: Specifies the width of Text in pixels.
    • Height: Specifies the height of the Text in pixels.
    • Size: Specifies the coordinates of the Text in [Width, Height].
    • Text: Specifies the onscreen label name of the Text.
    • Tech Name: This field maintains the GuiXT technical name of the Text.
    • Field Name: This field specifies the field name of the Text.
      Note: Original SAP Information parameters are non-editable.
  2. Enhancements: To edit the Text property, you can edit with Enhancements. It includes the following options:
    • Row: Specifies the onscreen row number of the Text.
    • Column: Specifies the onscreen column number of the Text.
    • Width: Specifies the width of Text in pixels.
    • Height: Specifies the height of the Text in pixels.
    • Text: Specifies the onscreen label name of the Text.
    • Relative To: Specifies if the element is being positioned relative to another screen element.
  3. Mark: To edit the Text property, you can edit with Mark section. It includes the following options:
    • isMark: Specifies if the Text is marked or not.
    • MarkOptions: Specifies if marked Text is colored to make it stand out. The color checkboxes located below this field are the various colors you can use to mark Text.
    • Image: If the element is linked to an image, the image path is specified here.
    • ViewHelp: If the element is associated with any viewhelp, the source can be specified here.
    • ViewHelp Height: Specifies the actual height of the viewhelp window in pixels. Check the smaller checkbox to use the number as a percentage of the orginal size.
    • ViewHelp Width: Specifies the actual width of the viewhelp window in pixels. Check the smaller checkbox to use the number as a percentage of the orginal size.
    • ViewHelp Position: Specifies the onscreen position of the viewhelp window in pixels. This can be either the actual position (absolute) or the position relative to another element.
  4. Tip: Allows you to add a tooltip to the Text element.

Can't find the answers you're looking for?