Liquid UI - Documentation - 1.02.08 Display Pop-up Window

1.02.08 Display Pop-up Window


A pop-up window can be displayed in Offline while the contents of said window can be captured. This is particularly useful when it is necessary to use pop-up windows for users to enter names and passwords. In these cases, once the Enter key has been pressed, the synchronization with SAP will begin. These kinds of use cases can be accomplished by using custom functions in Offline. The process is as follows:

  1. Create a custom function which in turn will create the screen elements to be used in the pop-up. These elements will be housed in an array. This custom function will take two parameters, as defined below:
    • Dynpro name: This parameter contains the name of the screen. By specifying the screen name, we can instruct Offline as to what type of screen should be displayed to the user. In this example, we will use the name 'SASPSMYST'.
    • Dynpro number: The screen number that is associated with the screen, eg. 0040.
  2. Call the custom function to display the pop-up window as shown in the following example.
     
    customSearchPopup.call(this,"SAPMSYST","0040",arNestFunctionDefinitions,{top:5, left:15,bottom:25,rigth:80});
    function customSearchPopup(strDynProName,strDynProNum,strCustomFunctionCode,objPosition) {
    objPosition = (objPosition == undefined ? objPosition:{top:objPosition.top,left:objPosition.left,bottom:objPosition.bottom,right:objPosition.right});
    var mySearchDefinitions = [
    // screen definitions go here
    ];
    this.addScreen(mySearchDefinitions.concat(strCustomFunctionCode));
    

Can't find the answers you're looking for?