Liquid UI - Documentation - 7.18 usecss()

7.18 usecss()


Purpose

With usecss(), you can modify Web Server css files.

This command can modify the included CSS format in the WS Web Server. These modifications are usually for personalizing the WS platform to match a customer's corporate environment but can be for a variety of purposes. Some possible uses might be to add a background image or to specify an external location for a CSS file. In this article, we will demonstrate how to use the usecss command.


Options

The usecss command does not take any options.

Adding a background image

To add a background image to the CSS:

usecss("string");

The string in the preceding syntax would include the specifications for the background image. For example, if you wish to use the image file 'Synactive.jpg', add the following code in the config.sjs file in the C:\Program Files\Synactive Inc\GuiXTFuzion directory:

usecss("body.urBdyStd{background-image: url('.demo_images/synactive.jpg'); No-repeat;}");

On execution of the code, the image gets added as a background image to the server. CSS files are also maintained in the server.

Specifying an external CSS file

You can also specify an external file to use as the CSS file with GuiXT Web Server:

usecss("C:\\Program Files\\Synactive Inc\\GuiXTFuzion\\test.css");

Liquid UI Web Server will now use the specified file as the source for the CSS.


Can't find the answers you're looking for?