Liquid UI - Documentation - 23.01 Generating Liquid UI WS Scripts

23.01 Generating Liquid UI WS Scripts


Prerequisites


Purpose

This section explains as how the script gets generated by creating a launch pad for SAP screen.

Let us consider an example for designing a launch pad:

Perform following steps in order to design the above screen;

  • Delete screen elements
  • Create a functional Pushbutton on the screen to navigate to SAP transaction
  • Add an icon to the Pushbutton


User Interface

Delete Screen Element

  • Select screen element with mouse click
  • Right click and select delete option or press “Delete” key on the keyboard

Once the elements are deleted, the following screen will appear:


The command for deleting is:

del(“X[IMAGE_CONTAINER]”);

Create Groupbox

Select groupbox and click on screen


Specify title for the groupbox


The command for creating a groupbox is:

box([2,3], [10,90], “Launch Pad”);

Create Pushbutton

Select pushbutton and click on screen


Right click for properties window and specify pushbutton text


Select “Command” tab and specify transaction to launch on click of pushbutton


Click on button to launch specified transaction


The Command for pushbutton is as follows:

  • pushbutton([row1, col1],”pushbutton Label”, “fcode”,{“[optionname]”:”[value]”,..});
  • pushbutton([row1, col1],”pushbutton Label”, {“process”:function_name,”[optionname]”,               “[value]”,..});
  • pushbutton([4,6], ‘Label’, “tcode”, {“size”:[row, col]});

The following would be the resulted screen after successful completion:


Sample Code

The following code is the generated script for designing the launch pad screen



Can't find the answers you're looking for?