Liquid UI - Documentation - 17.13 Hide scrollbars

17.13 Hide scrollbars


Prerequisites


Purpose

In this article, you will learn how to hide scrollbars on SAP screens. On an SAP screen, scrollbars can be turned off or hidden in a particular location by using the noscrollbar command. This is very useful when a user has to delete a large number of fields or other elements, eliminating the need for a scrollbar. The scrollbar at the right-hand edge of the window is the lone exception to the command - it is not disabled when using the noscrollbar command.

We'll guide you through the following steps.

  1. Delete the unnecessary screen elements
  2. Hide the scrollbar on the SAP screen


User Interface

//Create this file inside your script folder for customizing the Customer Change: Initial screen: SAPMF02D.E7000.sjs

//Now, let's add the Liquid UI script to the above file and save it.

  1. Log in to SAP and navigate to transaction XD02 (Customer Change: Initial screen). Enter the customer number and click continue, as shown below.
     
     
  2. Now, you will be navigated to the Change Customer: General Data screen, as shown below.
     
     
  3. Delete the Communication group box under the Address tab, as shown below.
     
    //Deletes the Communication group box from the SAP screen.
    del("G[Communication]");
     
     
  4. Now, using the noscrollbar(), we’ll hide the scrollbar of the Change Customer: General Data screen. You will see the scrollbar on the address tab is hidden, as shown below.
     
    //Hides the existing scrollbar
    noscrollbar();
     
     

Can't find the answers you're looking for?