Liquid UI - Documentation - 10.17 Get the first visible column position, last visible column position, data width and total width of a listscreen

10.17 Get the first visible column position, last visible column position, data width and total width of a listscreen


Prerequisites


Purpose

Learn how to find the first visible column position, last visible column position, data width of the visible screen, and total width of a list screen in SAP. These variables are useful in retrieving values based on their position.


User Interface

//Create this file inside your script folder for customizing SD Documents screen RVKRED01.E0120.sjs
//Now, let's start adding the Liquid UI script to the above file and save it.


Customization

  1. Add the following Liquid UI script code to this file, and save it.
     
    //_listfirstvisiblecol specifies the first column of a list screen
    println("First visible column number is:" +_listfirstvisiblecol);

    //_listLastvisiblecol specifies the last visible column of a list screen.
    println("Last visible column number is>>" + _listlastvisiblecol);

    //_listdatawidth specifies the width of the visible screen.
    println("Data Width of the list screen is>>" + _listdatawidth);

    //_listtotalwidth specifies the total table width on a list screen.
    println("Total Width of the list screen is >>" + _listtotalwidth);
     


SAP Process

  1. Navigate to the Blocked SD Documents (VKM1), and click on the execute button on the screen to display the output in the Cornelius window.
     
     
  2. Then the following screen appears. Now, open the Cornelius window to view the first visible column position, last visible column position, the data width of the visible screen, and the total width of the list screen, as shown in the image below.
     
     

Can't find the answers you're looking for?