Liquid UI - Documentation - 19.19 Reference multiple selection fields

19.19 Reference multiple selection fields


Prerequisites


Purpose

This article guides you through the process of displaying a multiple-selection pop-up for a field across various screens. For this, we’ve considered the SAP Easy Access screen as an instance and will walk through the following:

  1. Delete the image container on the SAP Easy Access screen
  2. Add two input fields to enter the values
  3. Add a push button to display multiple selection pop-up
  4. Add a function to pull up multiple selection pop-up


User Interface

//Create this file inside your script folder for customizing the SAP Easy Access screen, SAPLSMTR_NAVIGATION.E0100.sjs

//Now, let's add the Liquid UI script to the above file and save it.


Customization

  1. Delete the image container on the SAP Easy Access screen using del().
     
    // Deletes the image container
    del("X[IMAGE_CONTAINER]");
    
     
     
  2. Add two input fields labeled Purchasing Document and to to enter the document number range.
     
    //Created two input fields
    inputfield([1,1], "Purchasing Document", [1,25], {"size":10, "name":"z_vl10g_podocnum"});
    inputfield([1,45], "to", [1,60], {"size":10, "name":"z_vl10g_podocnumto"});
    
     
     
  3. Add a push button to display multiple selection pop-up
     
    //Create a push button Multiple selection for Purchase Orders with an icon
    pushbutton([1,75], "@1E\\QMultiple selection for Purchase Orders@", "/nVL10G", {"process":multipleselection, "using":{"l_tab":"PO","l_selection":"=%00210300000713501","l_field":"purchasedoc"}});    // Purchase Orders Tab
     
     
  4. Add a function to pull up the multiple selection pop-up
     
    // Function to pull up the multiple selection pop-up
    function multipleselection(param){
        onscreen 'RVV50R10C.1000'              // General Data Tab             
            if(param.l_tab == 'PO'){
                enter('=S0S_TAB5');            // Purchase Orders Tab                
            }

        onscreen 'RVV50R10C.1000'           // Purchase Orders Tab                           
            clearscreen();                    // To hide the screen background
            if(param.l_selection == '=%00210300000713501'){
                enter(param.l_selection);
            }

        RECHECK_POPUP:;
        onscreen 'SAPLALDB.3000'            // Popup for multiple selection
            goto RECHECK_POPUP;

        onscreen 'RVV50R10C.1000'              // Purchase Orders Tab                                     
            if(param.l_field == 'purchasedoc'){
                set("V[z_vl10g_podocnum]", "&F[ST_EBELN-LOW]");                    // Purchasing Document Number
                set("V[z_vl10g_podocnumto]", "&F[ST_EBELN-HIGH]");                // Purchasing Document Number to    
            }
            enter('/n');                       // Back to General Data Tab    
    }
     

SAP Process

  1. Refresh the SAP Easy Access screen. Enter the values in the input fields and click the multiple selection push button. This action displays selections for purchasing documents, as shown below.
     

Can't find the answers you're looking for?