Liquid UI - Documentation - 12.06 Hiding SAP columns

12.06 Hiding SAP columns


Prerequisites

Purpose

In this article, you will learn about how to hide the columns of an SAP native table. We can hide a native SAP column in a table using columnwidth(). Just set the width of the column to zero to hide or remove the column from view. The columnwidth() first takes a string of the table’s name followed by a comma and then the column you wish to resize. Ensure that extra spaces are not included unless there is space in the table or column’s name. The second parameter in the command is an integer, which indicates the size of that column.

Syntax

columnwidth()"table name, column name","options":values;

User Interface

//Create this file inside your script folder for customizing the Create Material screen. SAPMV45A.E4001.sjs 
//Now, let's start adding the Liquid UI script to the above file and save it.

To demonstrate how to hide the columns of an SAP native table, we'll guide you through the following steps.

  1. Hide the following columns of an SAP native table in VA02 transaction by setting their widths to 0. Columns are as follows:
    • SU
    • Customer Material Numb
    • Itca
    • Engin.Change
    • ATP quantity
    • PayG
    // Hidies the following columns by setting their width's to 0
    columnwidth("All items,SU",0);
    columnwidth("All items,Customer Material Numb",0);
    columnwidth("All items,ItCa",0);
    columnwidth("All items,Batch",0);
    columnwidth("All items,Engin.Change",0);
    columnwidth("All items,ATP quantity",0);
    columnwidth("All items,PayG",0);


    SAP Process

    1. Logon to SAP and navigate to the VA02 screen. Enter a sales order number and click enter. Then, you will be navigated to the Change Sales Order: Overview screen and the specified columns are hidden from the table, as shown in the image below.

Can't find the answers you're looking for?