Liquid UI - Documentation - 10.06 Get any cell value of a listscreen using _liststring

10.06 Get any cell value of a listscreen using _liststring


Prerequisites


Purpose

Learn how to read the cell value on a list screen using _liststring WS system variable. Double-click on any cell on the list screen, then _liststring variable loads that particular cell value in it. To demonstrate this, we’ll walk you through the following steps.

  1. Set the _liststring value
  2. Add the println statement to display the value in the Cornelius window


User Interface

//Create this file inside your script folder for customizing Release Purchasing Documents for Release Code RM06EF00.E0120.sjs
//Now, let's start adding the Liquid UI script to the above file and save it.


Customization

  1. Log into SAP, and navigate to the ME28 (Release (Approve) Purchase Documents) screen. Now, assign the value for Release Code as r3, and then click the execute button. You will be navigated to the Release Purchasing Documents with Release Code R3 screen, as shown in the image below.
     
     
  2. Now, set the _liststring value into a LiquidUI variable.
     
    //setting the _liststring value into a LiquidUI variable
    set("V[z_ls_data]",_liststring);
     
  3. Add a println statement to display the retrieved value in the z_ls_data variable on the Cornelius window.
     
    //variable value will be displayed on the cornelius output
    println("-------the value is-------"+z_ls_data);
    
     
  4. Now, refresh the Release Purchasing Documents with Release Code R3 screen, and double-click on any cell of the list screen. You can view the value of that particular cell in the Cornelius window, as shown in the image below.
     
     

     

Can't find the answers you're looking for?