Liquid UI - Documentation - 12.01 Create a launch pad for one-click navigation

12.01 Create a launch pad for one-click navigation


Prerequisites


Purpose

You will learn how to create a launch pad for one-click navigation to SAP transactions like VA01, IW21, MM01 on SAP Easy Access screen.

//Create this file inside your script folder for customizing SAP Easy Access screen: SAPLSMTR_NAVIGATION.E0100.sjs
//Now let's start adding the content to the above file

  1. Delete the image container
    del('X[IMAGE_CONTAINER]');
     

     
  2. Add a groupbox on the screen.
    You can organize the screen elements inside the box.
    box([2,0],[12,46],'Launch Pad');
    
     

     
  3. Add the required number of pushbuttons in the groupbox.
    On-click, Create Material pushbutton will navigate to Create Material screen, Create Sales Order pushbutton will navigate to Create Sales Order screen and Create Notification pushbutton will navigate to Create Notification.
    pushbutton([5,9],"Create Material","/nmm01");
    pushbutton([7,9],"Create Sales Order","/nva01");
    pushbutton([9,9],"Create Notification","/niw21");
    
     

     


Next Steps


10 min.

This article is part of the 2.0 Create your own launchpad on SAP Easy Access screen tutorial.


Can't find the answers you're looking for?