Liquid UI - Documentation - 23.16 Pass values between sessions

23.16 Pass values between sessions


Prerequisites


Purpose

Values can be passed between sessions as a parameter with "using" option.


User Interface

Click on Pass values button on toolbar to pass order type value in a new session


Liquid UI Script

Note: When you are passing values between sessions, function should be loaded in esession file since we are opening a new session.

//esession.sjs

load('functions_iw31.sjs'); 

//functions_iw31.sjs

function open_new_session(param){
    onscreen 'SAPLCOIH.0100'
    set('F[Order Type]',param.z_order_type);
    enter('?');
}

//SAPLSMTR_NAVIGATION.E0100.sjs

pushbutton([TOOLBAR], "Pass Values", "/oiw31",{"process":open_new_session, "using":{"z_order_type":"PM01" }});

Can't find the answers you're looking for?