Skip to content

LiquidUI/OpenWS

Repository files navigation

WS logo

WebScript Programming Language

Welcome to WebScript!

WebScript (WS) is a JavaScript-based scripting language for SAP customization. It enables you to optimize and streamline SAP without having to rebuild the whole transaction while preserving transaction richness.

WS core features include object structures, functions, and human-readable syntaxes. Every generated scripts by default are scalable, memory safe and can be easily extended to the mobile environment.

Downloading from OpenWS

This repository is filled with different solutions and demos for all types of business processes in SAP.

To try any of these scripts out, you must have Liquid UI for SAP GUI. If you are interested in a trial version, please call +1.650.341.3310 or email us at rfi@guixt.com.

OpenWS Through GitHub

Click on the module you would like to download and a list of files will be presented. Through the Github website, you can download each file one at a time.

Click on the file you want to download. On the top right, click the "Raw" button. Lastly, right click on the webpage and click Save As to save the file with whatever name you'd like. Once you have downloaded all the files for the module, set your script directory, in the guixt.sjs configuration file, to point the the newly downloaded scripts and try them out.

OpenWS Through SAP GUI

Not familiar with Github? No problem, we have developed a SAP GUI interface! This will allow you to download modules with one click from within SAP GUI. You can even activate the modules immediately after they are download to try them out. All you need are two files: init_OpenWS.sjs and wscurl.dll. Email us at support@guixt.com and we will give the files and help you get set up.

Contributing to OpenWS

In an endeavor to become a profoundly eminent community, Liquid UI embraces developers with different and unique experiences. We truly believe that a diverse, amiable and a benevolent community will hold more fresh ideas, various unique perspectives, and produce more great code. Therefore, contributions to OpenWS are welcomed and encouraged! We will work diligently to make the Liquid UI community welcoming for everyone.

To upload your own module to OpenWS, zip up your scripts folder and email us at support@guixt.com with the attachment. These scripts will be reviewd by one of our Support Engineers to ensure they are up to Liquid UI's standards. The module can be a current solution your company is using, a solution you have developed just for fun, or even just some demo screens, illustrating the possibilities of Liquid UI WS.

FileList.JSON

One important file to include in your zipped script folder is FileList.JSON

This file has all the total files in the script folder listed out in a JSON object. All our modules contain this file, below is an example:

[
  {"name":"SAPLSMTR_NAVIGATION.E0100.sjs"},
  {"name":"SAPLSMTR_NAVIGATION.E0101.sjs"},
  {"name":"SAPMV45A.E4001.sjs"},
  {"name":"CompanyLogo.png"}
]

Preview.PNG

Want to show a preview of what your solution looks like? Include a Preview.PNG file in your zipped script folder. This can be very helpful for a developer to get an idea of what your solution should look like without having to download the files.

Disclaimer

The content provided in this repository is for general educational purposes only. Synactive Inc does not warrant the accuracy or completeness of any information contained within this repository. It may be advisable for you to consult with a professional to get advice that applies to your specific implementation.

SAP and all SAP logos are trademarks or registered trademarks of SAP AG in Germany and in several other countries. All other product and service names mentioned are the trademarks of their respective companies.

© 2017 Synactive Inc. All Right Reserved

About

OpenWS is a web repository created to help you learn and develop WebScript through functioning examples along with showcasing your work for SAP customization.

Resources

Stars

Watchers

Forks

Releases

No releases published

Packages

No packages published