Liquid UI - Documentation - 8.07 rfcconnect

8.07 rfcconnect


Purpose

The rfcconnect command, along with the associated rfcuser and rfcpassword, is used to make remote calls between two SAP systems or between an SAP system and a non_SAP system, such as a GuiXT Server. In order to log on to the SAP system, the RFC needs a username and password. The password can be either encrypted or in plain text. Synactive recommends that you create a new RFC user in SAP, and give that user the appropriate rights.

The rfcconnect command specifies connection strings for one or more SAP application servers. This command is usually found in the guixt.sjs configuration file and is used to send a connection string specifying the SAP ERP system to which the RFC user will connect.


Syntax

rfcconnect="IFDATABASE=XXX,LANG=E,CLIENT=xxx,ASHOST=SAP_system,SYSNR=00,LCHECK=0,USE_SAP GUI=0,USER=rfc_user,PASSWD=rfc_password";
Note: If the password is encrypted, the plain text password will be replaced with the 'PASSWD' parameter by an encrypted string. Beginning with WS release 1.2.157.0, the username and password are no longer required for an rfcconnect statement. Instead, this data is read from the rfcuser and rfcpassword entries in the guixt.sjs file.
 

About RFC

The RFC data can be invoked in two other ways - either from the RFC parameters in the guixt.sjs file as explained in the GuiXT.sjs Parameters section or from a call command as explained in the call section. In order of precedence, the rfcconnect array takes precedence, followed in order by the call command and finally the single RFC user entry in the guixt.sjs file.
The GuiXT functionality that requires RFC is as follows.
  • Calling scripts from the SAP Web Repository (SAPWR)

    Note: When you are connecting to a Web Repository, the RFC username, password and connection setting must be included in a single rfcconnect statement in the guixt.sjs file - it cannot be invoked from any other location.
  • Using call statements in scripts
  • Using SAP Roles in scripts
  • Reading data dictionary items
  • Reading scripts from transaction variants
  • Reading images from 'SAPDB...'
  • Reading images from 'SAPIM...' (Business Document Server)

The table below contains the GuiXT actions that require RFC. In addition, the table contains the following information for each action:

  • The client in which the logon occurs
  • The name of the remote function called
  • The SAP user rights required to perform the action
ActionClientFunctionRFC Permissions
Read Script For Transaction Variants OOO RS_HDSYS_GET_ GUIXT_SCRIPT S_RFC:

RFC_TYPE=FUGR, RFC_NAME=SURL, ACTVT=16

Read SAPWR Objects 000 WWW_DISPATCH_ REQUEST S_RFC:

RFC_TYPE=FUGR, RFC_NAME=SURL, ACTVT=16

Use Call Statement in Script

Value specified in script.

Value specified in script.

S_RFC:

RFC_TYPE=FUGR, RFC_NAME=xxxx, ACTVT=16

Note: The value 'xxxx' is the functional group of the function you are calling.

Role-based access restriction

BAPI_USER_GET DETAIL

See examples for custom functions and sample code. S_RFC:

RFC_TYPE=FUGR, RFC_NAME=xxxx, ACTVT=16

S_USER_GRP

CLASS=SUPER, ACTVT=90

S_USER_SYS

CLASS=SUPER, ACTVT=90 (if using central user administration)

Profile-based access restriction

BAPI_USER_GET DETAIL

See examples for custom functions and sample code. S_RFC:

RFC_TYPE=FUGR, RFC_NAME=xxxx, ACTVT=16

S_USER_GRP

CLASS=SUPER, ACTVT=90

S_USER_SYS

CLASS=SUPER, ACTVT=90 (if using central user administration)

Reading images from 'SAPDB...' 000 RS_HDSYS_GET_ GUIXT_IMAGE S_RFC:

RFC_TYPE=FUGR, RFC_NAME=xxxx, ACTVT=16

Note: Value 'xxxx' is defined in the script.
Reading images from 'SAPIM'... 000 RS_HDSYS_GET_ BDS_IMAGE S_RFC:

RFC_TYPE=FUGR, RFC_NAME=RSIMG, ACTVT=16

S_BDS_DS:

CLASSNAME=cccc, CLASSTYP=OT, ACTVT=30

Note: Value 'cccc' is the class name of the BDS image file.

Can't find the answers you're looking for?