Author Topic: LiquidUI: Search Option in Set Command  (Read 2237 times)

chirag.amin@guixt.com

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 34
    • View Profile
LiquidUI: Search Option in Set Command
« on: January 06, 2017, 02:25:40 PM »
In a previous forum, a generic search function was created:

•   http://www.guixt.com/forum/index.php?topic=101.0

This feature is now in built since version 1.2.305. This is a very useful option used in the set command. It is most commonly used to help the developer pull out a document number from a message given by SAP. Here is an basic example of the command to illustrate it's functionality and syntax.

LiquidUI Code:


//SAPLSMTR_NAVIGATION.E0100.sjs
save_message = "Material document 312134 has been saved.";
// "document" is the string that is being searched for from V[save_message]
set("V[mat_doc_num]", "&V[save_message]", {"search":"document"});
// V[mat_doc_num] will store the next word after the searching string: "document"
message("S:&V[mat_doc_num] was created!!");